summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Klausner <wiz@NetBSD.org>2014-02-25 21:41:28 +0100
committerAliaksey Kandratsenka <alk@tut.by>2014-03-01 11:34:04 -0800
commit91179961490a601f2c611889b3075e995fa5437e (patch)
treef42d1a0d95d6dde8c5487e53eef045fe0aa79764 /configure.ac
parentfd3379a213b2a99a72a7544b6208056daf15d0d2 (diff)
downloadgperftools-91179961490a601f2c611889b3075e995fa5437e.tar.gz
Look for backtrace() in libexecinfo as well.
Signed-off-by: Aliaksey Kandratsenka <alk@tut.by>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a15276e..3d135c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -207,8 +207,9 @@ fi
# Some tests test the behavior of .so files, and only make sense for dynamic.
AM_CONDITIONAL(ENABLE_STATIC, test "$enable_static" = yes)
-# We want to link in libunwind if it exists
+# We want to link in libunwind or libexecinfo if it exists
AC_CHECK_LIB(unwind, backtrace, UNWIND_LIBS=-lunwind, UNWIND_LIBS=)
+AC_CHECK_LIB(execinfo, backtrace, UNWIND_LIBS=-lexecinfo, UNWIND_LIBS=)
AC_SUBST(UNWIND_LIBS)
# On x86_64, instead of libunwind, we can choose to compile with frame-pointers.