summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorchappedm@gmail.com <chappedm@gmail.com@6b5cf1ce-ec42-a296-1ba9-69fdba395a50>2012-11-03 14:13:21 +0000
committerchappedm@gmail.com <chappedm@gmail.com@6b5cf1ce-ec42-a296-1ba9-69fdba395a50>2012-11-03 14:13:21 +0000
commitc566266b10d2fc4e0c67fec25e2a45ebad803196 (patch)
treece362addbc8742c7adc27d3c8232b2f6ca7fa661 /configure.ac
parent4f325fbcc9f0db17fbf108188a32b2c67bcd38e0 (diff)
downloadgperftools-c566266b10d2fc4e0c67fec25e2a45ebad803196.tar.gz
issue-480: duplicate of issue-385 fixed in r150 however some of the comments in the code
regarding frame pointers needed to be clarified. git-svn-id: http://gperftools.googlecode.com/svn/trunk@165 6b5cf1ce-ec42-a296-1ba9-69fdba395a50
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 31ab69e..9e093b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -214,16 +214,14 @@ AM_CONDITIONAL(ENABLE_STATIC, test "$enable_static" = yes)
AC_CHECK_LIB(unwind, backtrace, UNWIND_LIBS=-lunwind, UNWIND_LIBS=)
AC_SUBST(UNWIND_LIBS)
-# On x86_64, instead of libunwind, we can choose to compile with frame-pointers
-# (This isn't needed on i386, where -fno-omit-frame-pointer is the default).
+# On x86_64, instead of libunwind, we can choose to compile with frame-pointers.
AC_ARG_ENABLE(frame_pointers,
AS_HELP_STRING([--enable-frame-pointers],
[On x86_64 systems, compile with -fno-omit-frame-pointer (see INSTALL)]),
, enable_frame_pointers=no)
AM_CONDITIONAL(ENABLE_FRAME_POINTERS, test "$enable_frame_pointers" = yes)
-# Some x86_64 systems do not insert frame pointers by default (all
-# i386 systems that I know of, do. I don't know about non-x86 chips).
+# Some x86_64 systems do not insert frame pointers by default.
# We want to see if the current system is one of those.
AC_COMPILE_IFELSE([AC_LANG_PROGRAM(, [return __x86_64__ == 1 ? 0 : 1])],
[is_x86_64=yes], [is_x86_64=no])