summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAliaksey Kandratsenka <alkondratenko@gmail.com>2018-08-26 11:37:59 -0700
committerAliaksey Kandratsenka <alkondratenko@gmail.com>2018-08-26 11:37:59 -0700
commit954f9dc0e37ff46cb0cb24edfb39dc77fd2e7d0b (patch)
tree2bf6be31b4cefd51209b11cc084e838850719d26 /Makefile.am
parent893bff51bcf220b724a812d340d878b5fb8ce911 (diff)
downloadgperftools-954f9dc0e37ff46cb0cb24edfb39dc77fd2e7d0b.tar.gz
Add flag to disable installing unmaintained & deprecated pprof.
Everyone should be using golang pprof from github.com/google/pprof, but distros still ship our perl version and not everyone is aware of better pprof yet. This is another step in completely dropping perl pprof. We still default to installing it, but hopefully we'll be able to convince distros to disable this soon. We still install pprof under pprof-symbolize name because stack traces symbolization depends on it, and because golang pprof won't support this feature. This is related to issue #1038.
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 04ff5af..be1db83 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -392,7 +392,10 @@ endif WITH_STACK_TRACE
# If we are not compiling with stacktrace support, pprof is worthless
if WITH_STACK_TRACE
-bin_SCRIPTS = src/pprof
+bin_SCRIPTS = pprof-symbolize
+
+pprof-symbolize : $(top_srcdir)/src/pprof
+ cp -p $(top_srcdir)/src/pprof $@
### Unittests
@@ -403,9 +406,13 @@ pprof_unittest: $(top_srcdir)/src/pprof
# Let unittests find pprof if they need to run it
TESTS_ENVIRONMENT += PPROF_PATH=$(top_srcdir)/src/pprof
-### Documentation
+if INSTALL_PPROF
+bin_SCRIPTS += src/pprof
dist_man_MANS = docs/pprof.1
dist_doc_DATA += docs/pprof_remote_servers.html
+endif INSTALL_PPROF
+
+### Documentation
# On MSVC, we need our own versions of addr2line and nm to work with pprof.
WINDOWS_PROJECTS += vsprojects/nm-pdb/nm-pdb.vcxproj