summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAliaksey Kandratsenka <alk@tut.by>2015-10-04 11:15:37 -0700
committerAliaksey Kandratsenka <alkondratenko@gmail.com>2015-11-21 17:43:42 -0800
commit88686972b9caf8fd132c4e30d89da78c3d324c27 (patch)
treef36c68a039e9176c9855a46a2faa9e3296be3d4b /Makefile.am
parent0a18fab3af2f1b59b851836d319a1eff0db5d44e (diff)
downloadgperftools-88686972b9caf8fd132c4e30d89da78c3d324c27.tar.gz
pass -fsized-deallocation to gcc 5
Otherwise it gives warning for declaration of sized delete operator.
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b5f4725..70d26c8 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -48,6 +48,9 @@ endif GCC
if HAVE_W_NO_UNUSED_RESULT
AM_CXXFLAGS += -Wno-unused-result
endif HAVE_W_NO_UNUSED_RESULT
+if HAVE_SIZED_DEALLOCATION
+AM_CXXFLAGS += -fsized-deallocation
+endif HAVE_SIZED_DEALLOCATION
# The -no-undefined flag allows libtool to generate shared libraries for
# Cygwin and MinGW. LIBSTDCXX_LA_LINKER_FLAG is used to fix a Solaris bug.