summaryrefslogtreecommitdiff
path: root/tests/warn/Makefile.am
diff options
context:
space:
mode:
authorJohan Dahlin <johan@gnome.org>2010-09-02 16:42:15 -0300
committerJohan Dahlin <johan@gnome.org>2010-09-02 16:43:57 -0300
commit64fe43160220f2145e8ce903772251f335e8ca2a (patch)
treee55d4d72847dd32549d130de0ebac9dd0ff6d211 /tests/warn/Makefile.am
parentbbd1aa9450e54ad57c017f408dae5937dcf074ac (diff)
downloadgobject-introspection-64fe43160220f2145e8ce903772251f335e8ca2a.tar.gz
[tests] Add test infrastructure for warnings
Add an infrastructure for testing warnings, add two examples how to verify warnings
Diffstat (limited to 'tests/warn/Makefile.am')
-rw-r--r--tests/warn/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/warn/Makefile.am b/tests/warn/Makefile.am
new file mode 100644
index 00000000..a1e274d3
--- /dev/null
+++ b/tests/warn/Makefile.am
@@ -0,0 +1,10 @@
+include $(top_srcdir)/common.mk
+
+warning_tests = \
+ return-gobject.h \
+ unresolved-type.h
+
+EXTRA_DIST = warningtester.py common.h $(warning_tests)
+
+check-local:
+ @PYTHONPATH=$(top_builddir):$(top_srcdir) $(PYTHON) $(srcdir)/warningtester.py $(warning_tests)