summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDieter Verfaillie <dieterv@optionexplicit.be>2013-04-24 14:06:18 +0200
committerDieter Verfaillie <dieterv@optionexplicit.be>2013-05-07 23:38:22 +0200
commitc9e2d880011c530ff1454fe31a2d40d189860be5 (patch)
tree9acdf7d7cf409ffd8d0f7967ebf9d03497d31269 /Makefile.am
parenta031129d8ab28e2f51e95e7266f1274bdc592557 (diff)
downloadgobject-introspection-c9e2d880011c530ff1454fe31a2d40d189860be5.tar.gz
tests: Update misc/pep8.py to 1.4.5
Version in our tree is a wee bit outdated. For example, later work will introduce an utf8 encoded python source file which our old pep8.py does not yet understand (yeah, it really was *that* ancient)... Updated from: https://raw.github.com/jcrocholl/pep8/1.4.5/pep8.py Takes 552c1f1525e37a30376790151c1ba437776682c5, f941537d1c0a40f0906490ed160db6c79af572d3, 5a4afe2a77d0ff7d9fea13dd93c3304a6ca993de and a17f157e19bd6792c00321c8020dca5e5a281f45 into account... https://bugzilla.gnome.org/show_bug.cgi?id=699535
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 202464fa..c04c05a0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -55,10 +55,16 @@ EXTRA_DIST += \
misc/pep8.py \
misc/pyflakes.py
+# Default pep8.py --exclude + emacs backup files
+PEP8_EXCLUDES=--exclude='.svn,CVS,.bzr,.hg,.git,__pycache__,.\#*'
+
check-local:
gtester --verbose $(GTESTER_PROGS)
@echo "TEST: PEP-8 INQUISITION"
- @find $(top_srcdir)/giscanner -name \*.py | sort | uniq | xargs $(PYTHON) $(top_srcdir)/misc/pep8.py --repeat --exclude=config.py
+ @find $(top_srcdir)/giscanner -name \*.py | sort | uniq | xargs \
+ $(PYTHON) $(top_srcdir)/misc/pep8.py --max-line-length=99 --ignore=E128 $(PEP8_EXCLUDES)
+ @find $(top_srcdir)/tests -name \*.py | sort | uniq | xargs \
+ $(PYTHON) $(top_srcdir)/misc/pep8.py --ignore=E127,E501 $(PEP8_EXCLUDES)
@echo "TEST: Annotation pattern programs"
PYTHONPATH="$(top_builddir):$(top_srcdir)" $(PYTHON) $(top_srcdir)/tests/scanner/annotationparser/test_patterns.py
@echo "TEST: GTK-Doc Annotation Parser"