summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDieter Verfaillie <dieterv@optionexplicit.be>2013-04-10 00:00:37 +0200
committerColin Walters <walters@verbum.org>2013-04-21 08:34:33 -0400
commit274d4f28a00d1d2bbfc4a1fe4dbbd4ad545b1ec3 (patch)
tree71835f2996237c36ad988ee3ef1c91b2da7b10be /Makefile.am
parent0f207646c63c8ee919b3a99436a53b977aece094 (diff)
downloadgobject-introspection-274d4f28a00d1d2bbfc4a1fe4dbbd4ad545b1ec3.tar.gz
fix "make distcheck"
- Configure with --enable-doctool when running "make distcheck" - Remove $(top_builddir)/.make-check-passed as the pre-commit hook using this was removed in de84ea0cf212c251e099f456bb675492f664e93d - Fix CLEANFILES + manual rm invocations - Fix running warning tests uninstalled (VPATH build issue) https://bugzilla.gnome.org/show_bug.cgi?id=697669
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 736f3adb..202464fa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,7 +29,7 @@ ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
SUBDIRS = . docs tests build
DIST_SUBDIRS = m4 $(SUBDIRS)
-DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
+DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-doctool
man_MANS += \
docs/g-ir-compiler.1 \
@@ -63,7 +63,6 @@ check-local:
PYTHONPATH="$(top_builddir):$(top_srcdir)" $(PYTHON) $(top_srcdir)/tests/scanner/annotationparser/test_patterns.py
@echo "TEST: GTK-Doc Annotation Parser"
PYTHONPATH="$(top_builddir):$(top_srcdir)" $(PYTHON) $(top_srcdir)/tests/scanner/annotationparser/test_parser.py
- @touch $(top_builddir)/.make-check-passed
check-pyflakes:
@echo " CHECK Pyflakes"