summaryrefslogtreecommitdiff
path: root/tests/windows/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/windows/Makefile.am')
-rw-r--r--tests/windows/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/tests/windows/Makefile.am b/tests/windows/Makefile.am
index e8d4568e24..f8037a2715 100644
--- a/tests/windows/Makefile.am
+++ b/tests/windows/Makefile.am
@@ -30,7 +30,7 @@ if ENABLE_MINITASN1
AM_CPPFLAGS += -I$(top_builddir)/lib/minitasn1
endif
-EXTRA_DIST = ncrypt-int.h
+EXTRA_DIST = ncrypt-int.h check-output
AM_LDFLAGS = -no-install
LDADD = $(top_builddir)/tests/libutils.la \
@@ -50,16 +50,20 @@ crypt32_la_LIBADD = ../../gl/libgnu.la ../../lib/libgnutls.la -lmsvcrt -lkernel3
ncrypt_la_LDFLAGS = -module -no-undefined -avoid-version -Wl,--add-stdcall-alias
crypt32_la_LDFLAGS = -module -no-undefined -avoid-version -Wl,--add-stdcall-alias
-ctests += cng-windows
cng_windows_DEPENDENCIES = ncrypt.la crypt32.la
cng_windows_CPPFLAGS = $(AM_CPPFLAGS)
+LOG_COMPILER = ./check-output
+
endif
+ctests += cng-windows
+
check_PROGRAMS = $(ctests)
dist_check_SCRIPTS =
+
TESTS = $(ctests) $(dist_check_SCRIPTS)
TESTS_ENVIRONMENT = \