summaryrefslogtreecommitdiff
path: root/tests/suite/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/suite/Makefile.am')
-rw-r--r--tests/suite/Makefile.am18
1 files changed, 16 insertions, 2 deletions
diff --git a/tests/suite/Makefile.am b/tests/suite/Makefile.am
index d6f6ff135b..8cfb087eda 100644
--- a/tests/suite/Makefile.am
+++ b/tests/suite/Makefile.am
@@ -39,7 +39,19 @@ LDADD = ../../lib/libgnutls.la \
prime_check_LDADD = $(LDADD) -lhogweed -lgmp
scripts_to_test = chain.sh \
- testrng.sh testcompat-polarssl.sh testcompat-openssl.sh \
+ testrng.sh \
+ testcompat-polarssl-serv.sh \
+ testcompat-polarssl-serv-compat.sh \
+ testcompat-polarssl-serv-no-etm.sh \
+ testcompat-openssl-cli.sh \
+ testcompat-openssl-cli-compat.sh \
+ testcompat-openssl-cli-no-etm.sh \
+ testcompat-openssl-serv.sh \
+ testcompat-openssl-serv-compat.sh \
+ testcompat-openssl-serv-no-etm.sh \
+ testcompat-openssl-serv-no-tickets.sh \
+ testcompat-openssl-serv-no-safe-renegotiation.sh \
+ testcompat-openssl-serv-safe-renegotiation.sh \
testrandom.sh tls-fuzzer/tls-fuzzer-nocert.sh \
tls-fuzzer/tls-fuzzer-cert.sh tls-fuzzer/tls-fuzzer-alpn.sh \
tls-fuzzer/tls-fuzzer-nocert-tls13.sh tls-fuzzer/tls-fuzzer-psk.sh \
@@ -67,7 +79,9 @@ TESTS_ENVIRONMENT += ENABLE_SSL3=1
endif
if ENABLE_TLS13_INTEROP
-scripts_to_test += testcompat-tls13-openssl.sh
+scripts_to_test += \
+ testcompat-openssl-tls13-cli.sh \
+ testcompat-openssl-tls13-serv.sh
endif
if ENABLE_OLDGNUTLS_INTEROP