summaryrefslogtreecommitdiff
path: root/lib/gl/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/gl/tests/Makefile.am')
-rw-r--r--lib/gl/tests/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/lib/gl/tests/Makefile.am b/lib/gl/tests/Makefile.am
index e70c294d2d..a2d36fff91 100644
--- a/lib/gl/tests/Makefile.am
+++ b/lib/gl/tests/Makefile.am
@@ -31,6 +31,7 @@ DISTCLEANFILES =
MAINTAINERCLEANFILES =
AM_CPPFLAGS = \
+ -D@lgltests_WITNESS@=1 \
-I. -I$(srcdir) \
-I../.. -I$(srcdir)/../.. \
-I../../gl -I$(srcdir)/../../gl
@@ -86,6 +87,30 @@ EXTRA_DIST += test-byteswap.c macros.h
## end gnulib module byteswap-tests
+## begin gnulib module c++defs
+
+# The BUILT_SOURCES created by this Makefile snippet are not used via #include
+# statements but through direct file reference. Therefore this snippet must be
+# present in all Makefile.am that need it. This is ensured by the applicability
+# 'all' defined above.
+
+BUILT_SOURCES += c++defs.h
+# The c++defs.h that gets inserted into generated .h files is the same as
+# build-aux/c++defs.h, except that it has the copyright header cut off.
+c++defs.h: $(top_srcdir)/build-aux/c++defs.h
+ $(AM_V_GEN)rm -f $@-t $@ && \
+ sed -n -e '/_GL_CXXDEFS/,$$p' \
+ < $(top_srcdir)/build-aux/c++defs.h \
+ > $@-t && \
+ mv $@-t $@
+MOSTLYCLEANFILES += c++defs.h c++defs.h-t
+
+CXXDEFS_H=c++defs.h
+
+EXTRA_DIST += $(top_srcdir)/build-aux/c++defs.h
+
+## end gnulib module c++defs
+
## begin gnulib module c-ctype-tests
TESTS += test-c-ctype