summaryrefslogtreecommitdiff
path: root/lib/ext/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/ext/Makefile.am')
-rw-r--r--lib/ext/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/lib/ext/Makefile.am b/lib/ext/Makefile.am
index 0d97132537..1719fd75a4 100644
--- a/lib/ext/Makefile.am
+++ b/lib/ext/Makefile.am
@@ -39,5 +39,8 @@ libgnutls_ext_la_SOURCES = max_record.c cert_type.c \
max_record.h cert_type.h server_name.h srp.h \
session_ticket.h signature.h safe_renegotiation.h \
session_ticket.c srp.c ecc.c ecc.h heartbeat.c heartbeat.h \
- status_request.h status_request.c srtp.c srtp.h
+ status_request.h status_request.c
+if ENABLE_DTLS_SRTP
+libgnutls_ext_la_SOURCES += srtp.c srtp.h
+endif