summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index e35e92ffd0..ed6ee8371c 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -552,6 +552,7 @@ ENUMS += enums/gnutls_ecc_curve_t
ENUMS += enums/gnutls_ext_flags_t
ENUMS += enums/gnutls_ext_parse_type_t
ENUMS += enums/gnutls_fips_mode_t
+ENUMS += enums/gnutls_gost_paramset_t
ENUMS += enums/gnutls_group_t
ENUMS += enums/gnutls_handshake_description_t
ENUMS += enums/gnutls_init_flags_t
@@ -893,6 +894,8 @@ FUNCS += functions/gnutls_db_set_store_function
FUNCS += functions/gnutls_db_set_store_function.short
FUNCS += functions/gnutls_decode_ber_digest_info
FUNCS += functions/gnutls_decode_ber_digest_info.short
+FUNCS += functions/gnutls_decode_gost_rs_value
+FUNCS += functions/gnutls_decode_gost_rs_value.short
FUNCS += functions/gnutls_decode_rs_value
FUNCS += functions/gnutls_decode_rs_value.short
FUNCS += functions/gnutls_deinit
@@ -973,6 +976,8 @@ FUNCS += functions/gnutls_ecc_curve_list
FUNCS += functions/gnutls_ecc_curve_list.short
FUNCS += functions/gnutls_encode_ber_digest_info
FUNCS += functions/gnutls_encode_ber_digest_info.short
+FUNCS += functions/gnutls_encode_gost_rs_value
+FUNCS += functions/gnutls_encode_gost_rs_value.short
FUNCS += functions/gnutls_encode_rs_value
FUNCS += functions/gnutls_encode_rs_value.short
FUNCS += functions/gnutls_error_is_fatal
@@ -1015,6 +1020,10 @@ FUNCS += functions/gnutls_global_set_mutex
FUNCS += functions/gnutls_global_set_mutex.short
FUNCS += functions/gnutls_global_set_time_function
FUNCS += functions/gnutls_global_set_time_function.short
+FUNCS += functions/gnutls_gost_paramset_get_name
+FUNCS += functions/gnutls_gost_paramset_get_name.short
+FUNCS += functions/gnutls_gost_paramset_get_oid
+FUNCS += functions/gnutls_gost_paramset_get_oid.short
FUNCS += functions/gnutls_group_get
FUNCS += functions/gnutls_group_get.short
FUNCS += functions/gnutls_group_get_id
@@ -1213,6 +1222,8 @@ FUNCS += functions/gnutls_oid_to_digest
FUNCS += functions/gnutls_oid_to_digest.short
FUNCS += functions/gnutls_oid_to_ecc_curve
FUNCS += functions/gnutls_oid_to_ecc_curve.short
+FUNCS += functions/gnutls_oid_to_gost_paramset
+FUNCS += functions/gnutls_oid_to_gost_paramset.short
FUNCS += functions/gnutls_oid_to_mac
FUNCS += functions/gnutls_oid_to_mac.short
FUNCS += functions/gnutls_oid_to_pk
@@ -1557,6 +1568,8 @@ FUNCS += functions/gnutls_privkey_export_ecc_raw
FUNCS += functions/gnutls_privkey_export_ecc_raw.short
FUNCS += functions/gnutls_privkey_export_ecc_raw2
FUNCS += functions/gnutls_privkey_export_ecc_raw2.short
+FUNCS += functions/gnutls_privkey_export_gost_raw2
+FUNCS += functions/gnutls_privkey_export_gost_raw2.short
FUNCS += functions/gnutls_privkey_export_openpgp
FUNCS += functions/gnutls_privkey_export_openpgp.short
FUNCS += functions/gnutls_privkey_export_pkcs11
@@ -1591,6 +1604,8 @@ FUNCS += functions/gnutls_privkey_import_ext3
FUNCS += functions/gnutls_privkey_import_ext3.short
FUNCS += functions/gnutls_privkey_import_ext4
FUNCS += functions/gnutls_privkey_import_ext4.short
+FUNCS += functions/gnutls_privkey_import_gost_raw
+FUNCS += functions/gnutls_privkey_import_gost_raw.short
FUNCS += functions/gnutls_privkey_import_openpgp
FUNCS += functions/gnutls_privkey_import_openpgp.short
FUNCS += functions/gnutls_privkey_import_openpgp_raw
@@ -1689,6 +1704,8 @@ FUNCS += functions/gnutls_pubkey_export_ecc_raw2
FUNCS += functions/gnutls_pubkey_export_ecc_raw2.short
FUNCS += functions/gnutls_pubkey_export_ecc_x962
FUNCS += functions/gnutls_pubkey_export_ecc_x962.short
+FUNCS += functions/gnutls_pubkey_export_gost_raw2
+FUNCS += functions/gnutls_pubkey_export_gost_raw2.short
FUNCS += functions/gnutls_pubkey_export_rsa_raw
FUNCS += functions/gnutls_pubkey_export_rsa_raw.short
FUNCS += functions/gnutls_pubkey_export_rsa_raw2
@@ -1713,6 +1730,8 @@ FUNCS += functions/gnutls_pubkey_import_ecc_raw
FUNCS += functions/gnutls_pubkey_import_ecc_raw.short
FUNCS += functions/gnutls_pubkey_import_ecc_x962
FUNCS += functions/gnutls_pubkey_import_ecc_x962.short
+FUNCS += functions/gnutls_pubkey_import_gost_raw
+FUNCS += functions/gnutls_pubkey_import_gost_raw.short
FUNCS += functions/gnutls_pubkey_import_openpgp
FUNCS += functions/gnutls_pubkey_import_openpgp.short
FUNCS += functions/gnutls_pubkey_import_openpgp_raw
@@ -2375,6 +2394,8 @@ FUNCS += functions/gnutls_x509_crt_get_pk_dsa_raw
FUNCS += functions/gnutls_x509_crt_get_pk_dsa_raw.short
FUNCS += functions/gnutls_x509_crt_get_pk_ecc_raw
FUNCS += functions/gnutls_x509_crt_get_pk_ecc_raw.short
+FUNCS += functions/gnutls_x509_crt_get_pk_gost_raw
+FUNCS += functions/gnutls_x509_crt_get_pk_gost_raw.short
FUNCS += functions/gnutls_x509_crt_get_pk_oid
FUNCS += functions/gnutls_x509_crt_get_pk_oid.short
FUNCS += functions/gnutls_x509_crt_get_pk_rsa_raw
@@ -2659,6 +2680,8 @@ FUNCS += functions/gnutls_x509_privkey_export_dsa_raw
FUNCS += functions/gnutls_x509_privkey_export_dsa_raw.short
FUNCS += functions/gnutls_x509_privkey_export_ecc_raw
FUNCS += functions/gnutls_x509_privkey_export_ecc_raw.short
+FUNCS += functions/gnutls_x509_privkey_export_gost_raw
+FUNCS += functions/gnutls_x509_privkey_export_gost_raw.short
FUNCS += functions/gnutls_x509_privkey_export_pkcs8
FUNCS += functions/gnutls_x509_privkey_export_pkcs8.short
FUNCS += functions/gnutls_x509_privkey_export_rsa_raw
@@ -2689,6 +2712,8 @@ FUNCS += functions/gnutls_x509_privkey_import_dsa_raw
FUNCS += functions/gnutls_x509_privkey_import_dsa_raw.short
FUNCS += functions/gnutls_x509_privkey_import_ecc_raw
FUNCS += functions/gnutls_x509_privkey_import_ecc_raw.short
+FUNCS += functions/gnutls_x509_privkey_import_gost_raw
+FUNCS += functions/gnutls_x509_privkey_import_gost_raw.short
FUNCS += functions/gnutls_x509_privkey_import_openssl
FUNCS += functions/gnutls_x509_privkey_import_openssl.short
FUNCS += functions/gnutls_x509_privkey_import_pkcs8