summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am153
1 files changed, 0 insertions, 153 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 4e939ea684..d90349d75b 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -553,7 +553,6 @@ ENUMS += enums/gnutls_ocsp_cert_status_t
ENUMS += enums/gnutls_ocsp_print_formats_t
ENUMS += enums/gnutls_ocsp_resp_status_t
ENUMS += enums/gnutls_ocsp_verify_reason_t
-ENUMS += enums/gnutls_openpgp_crt_fmt_t
ENUMS += enums/gnutls_openpgp_crt_status_t
ENUMS += enums/gnutls_params_type_t
ENUMS += enums/gnutls_pin_flag_t
@@ -691,10 +690,6 @@ FUNCS += functions/gnutls_certificate_get_crt_raw
FUNCS += functions/gnutls_certificate_get_crt_raw.short
FUNCS += functions/gnutls_certificate_get_issuer
FUNCS += functions/gnutls_certificate_get_issuer.short
-FUNCS += functions/gnutls_certificate_get_openpgp_crt
-FUNCS += functions/gnutls_certificate_get_openpgp_crt.short
-FUNCS += functions/gnutls_certificate_get_openpgp_key
-FUNCS += functions/gnutls_certificate_get_openpgp_key.short
FUNCS += functions/gnutls_certificate_get_ours
FUNCS += functions/gnutls_certificate_get_ours.short
FUNCS += functions/gnutls_certificate_get_peers
@@ -727,20 +722,6 @@ FUNCS += functions/gnutls_certificate_set_ocsp_status_request_function
FUNCS += functions/gnutls_certificate_set_ocsp_status_request_function.short
FUNCS += functions/gnutls_certificate_set_ocsp_status_request_function2
FUNCS += functions/gnutls_certificate_set_ocsp_status_request_function2.short
-FUNCS += functions/gnutls_certificate_set_openpgp_key
-FUNCS += functions/gnutls_certificate_set_openpgp_key.short
-FUNCS += functions/gnutls_certificate_set_openpgp_key_file
-FUNCS += functions/gnutls_certificate_set_openpgp_key_file.short
-FUNCS += functions/gnutls_certificate_set_openpgp_key_file2
-FUNCS += functions/gnutls_certificate_set_openpgp_key_file2.short
-FUNCS += functions/gnutls_certificate_set_openpgp_key_mem
-FUNCS += functions/gnutls_certificate_set_openpgp_key_mem.short
-FUNCS += functions/gnutls_certificate_set_openpgp_key_mem2
-FUNCS += functions/gnutls_certificate_set_openpgp_key_mem2.short
-FUNCS += functions/gnutls_certificate_set_openpgp_keyring_file
-FUNCS += functions/gnutls_certificate_set_openpgp_keyring_file.short
-FUNCS += functions/gnutls_certificate_set_openpgp_keyring_mem
-FUNCS += functions/gnutls_certificate_set_openpgp_keyring_mem.short
FUNCS += functions/gnutls_certificate_set_params_function
FUNCS += functions/gnutls_certificate_set_params_function.short
FUNCS += functions/gnutls_certificate_set_pin_function
@@ -1183,144 +1164,10 @@ FUNCS += functions/gnutls_oid_to_pk
FUNCS += functions/gnutls_oid_to_pk.short
FUNCS += functions/gnutls_oid_to_sign
FUNCS += functions/gnutls_oid_to_sign.short
-FUNCS += functions/gnutls_openpgp_crt_check_email
-FUNCS += functions/gnutls_openpgp_crt_check_email.short
-FUNCS += functions/gnutls_openpgp_crt_check_hostname
-FUNCS += functions/gnutls_openpgp_crt_check_hostname.short
-FUNCS += functions/gnutls_openpgp_crt_check_hostname2
-FUNCS += functions/gnutls_openpgp_crt_check_hostname2.short
-FUNCS += functions/gnutls_openpgp_crt_deinit
-FUNCS += functions/gnutls_openpgp_crt_deinit.short
-FUNCS += functions/gnutls_openpgp_crt_export
-FUNCS += functions/gnutls_openpgp_crt_export.short
-FUNCS += functions/gnutls_openpgp_crt_export2
-FUNCS += functions/gnutls_openpgp_crt_export2.short
-FUNCS += functions/gnutls_openpgp_crt_get_auth_subkey
-FUNCS += functions/gnutls_openpgp_crt_get_auth_subkey.short
-FUNCS += functions/gnutls_openpgp_crt_get_creation_time
-FUNCS += functions/gnutls_openpgp_crt_get_creation_time.short
-FUNCS += functions/gnutls_openpgp_crt_get_expiration_time
-FUNCS += functions/gnutls_openpgp_crt_get_expiration_time.short
-FUNCS += functions/gnutls_openpgp_crt_get_fingerprint
-FUNCS += functions/gnutls_openpgp_crt_get_fingerprint.short
-FUNCS += functions/gnutls_openpgp_crt_get_key_id
-FUNCS += functions/gnutls_openpgp_crt_get_key_id.short
-FUNCS += functions/gnutls_openpgp_crt_get_key_usage
-FUNCS += functions/gnutls_openpgp_crt_get_key_usage.short
-FUNCS += functions/gnutls_openpgp_crt_get_name
-FUNCS += functions/gnutls_openpgp_crt_get_name.short
-FUNCS += functions/gnutls_openpgp_crt_get_pk_algorithm
-FUNCS += functions/gnutls_openpgp_crt_get_pk_algorithm.short
-FUNCS += functions/gnutls_openpgp_crt_get_pk_dsa_raw
-FUNCS += functions/gnutls_openpgp_crt_get_pk_dsa_raw.short
-FUNCS += functions/gnutls_openpgp_crt_get_pk_rsa_raw
-FUNCS += functions/gnutls_openpgp_crt_get_pk_rsa_raw.short
-FUNCS += functions/gnutls_openpgp_crt_get_preferred_key_id
-FUNCS += functions/gnutls_openpgp_crt_get_preferred_key_id.short
-FUNCS += functions/gnutls_openpgp_crt_get_revoked_status
-FUNCS += functions/gnutls_openpgp_crt_get_revoked_status.short
-FUNCS += functions/gnutls_openpgp_crt_get_subkey_count
-FUNCS += functions/gnutls_openpgp_crt_get_subkey_count.short
-FUNCS += functions/gnutls_openpgp_crt_get_subkey_creation_time
-FUNCS += functions/gnutls_openpgp_crt_get_subkey_creation_time.short
-FUNCS += functions/gnutls_openpgp_crt_get_subkey_expiration_time
-FUNCS += functions/gnutls_openpgp_crt_get_subkey_expiration_time.short
-FUNCS += functions/gnutls_openpgp_crt_get_subkey_fingerprint
-FUNCS += functions/gnutls_openpgp_crt_get_subkey_fingerprint.short
-FUNCS += functions/gnutls_openpgp_crt_get_subkey_id
-FUNCS += functions/gnutls_openpgp_crt_get_subkey_id.short
-FUNCS += functions/gnutls_openpgp_crt_get_subkey_idx
-FUNCS += functions/gnutls_openpgp_crt_get_subkey_idx.short
-FUNCS += functions/gnutls_openpgp_crt_get_subkey_pk_algorithm
-FUNCS += functions/gnutls_openpgp_crt_get_subkey_pk_algorithm.short
-FUNCS += functions/gnutls_openpgp_crt_get_subkey_pk_dsa_raw
-FUNCS += functions/gnutls_openpgp_crt_get_subkey_pk_dsa_raw.short
-FUNCS += functions/gnutls_openpgp_crt_get_subkey_pk_rsa_raw
-FUNCS += functions/gnutls_openpgp_crt_get_subkey_pk_rsa_raw.short
-FUNCS += functions/gnutls_openpgp_crt_get_subkey_revoked_status
-FUNCS += functions/gnutls_openpgp_crt_get_subkey_revoked_status.short
-FUNCS += functions/gnutls_openpgp_crt_get_subkey_usage
-FUNCS += functions/gnutls_openpgp_crt_get_subkey_usage.short
-FUNCS += functions/gnutls_openpgp_crt_get_version
-FUNCS += functions/gnutls_openpgp_crt_get_version.short
-FUNCS += functions/gnutls_openpgp_crt_import
-FUNCS += functions/gnutls_openpgp_crt_import.short
-FUNCS += functions/gnutls_openpgp_crt_init
-FUNCS += functions/gnutls_openpgp_crt_init.short
-FUNCS += functions/gnutls_openpgp_crt_print
-FUNCS += functions/gnutls_openpgp_crt_print.short
-FUNCS += functions/gnutls_openpgp_crt_set_preferred_key_id
-FUNCS += functions/gnutls_openpgp_crt_set_preferred_key_id.short
-FUNCS += functions/gnutls_openpgp_crt_verify_ring
-FUNCS += functions/gnutls_openpgp_crt_verify_ring.short
-FUNCS += functions/gnutls_openpgp_crt_verify_self
-FUNCS += functions/gnutls_openpgp_crt_verify_self.short
-FUNCS += functions/gnutls_openpgp_keyring_check_id
-FUNCS += functions/gnutls_openpgp_keyring_check_id.short
-FUNCS += functions/gnutls_openpgp_keyring_deinit
-FUNCS += functions/gnutls_openpgp_keyring_deinit.short
-FUNCS += functions/gnutls_openpgp_keyring_get_crt
-FUNCS += functions/gnutls_openpgp_keyring_get_crt.short
-FUNCS += functions/gnutls_openpgp_keyring_get_crt_count
-FUNCS += functions/gnutls_openpgp_keyring_get_crt_count.short
-FUNCS += functions/gnutls_openpgp_keyring_import
-FUNCS += functions/gnutls_openpgp_keyring_import.short
-FUNCS += functions/gnutls_openpgp_keyring_init
-FUNCS += functions/gnutls_openpgp_keyring_init.short
-FUNCS += functions/gnutls_openpgp_privkey_deinit
-FUNCS += functions/gnutls_openpgp_privkey_deinit.short
-FUNCS += functions/gnutls_openpgp_privkey_export
-FUNCS += functions/gnutls_openpgp_privkey_export.short
-FUNCS += functions/gnutls_openpgp_privkey_export2
-FUNCS += functions/gnutls_openpgp_privkey_export2.short
-FUNCS += functions/gnutls_openpgp_privkey_export_dsa_raw
-FUNCS += functions/gnutls_openpgp_privkey_export_dsa_raw.short
-FUNCS += functions/gnutls_openpgp_privkey_export_rsa_raw
-FUNCS += functions/gnutls_openpgp_privkey_export_rsa_raw.short
-FUNCS += functions/gnutls_openpgp_privkey_export_subkey_dsa_raw
-FUNCS += functions/gnutls_openpgp_privkey_export_subkey_dsa_raw.short
-FUNCS += functions/gnutls_openpgp_privkey_export_subkey_rsa_raw
-FUNCS += functions/gnutls_openpgp_privkey_export_subkey_rsa_raw.short
-FUNCS += functions/gnutls_openpgp_privkey_get_fingerprint
-FUNCS += functions/gnutls_openpgp_privkey_get_fingerprint.short
-FUNCS += functions/gnutls_openpgp_privkey_get_key_id
-FUNCS += functions/gnutls_openpgp_privkey_get_key_id.short
-FUNCS += functions/gnutls_openpgp_privkey_get_pk_algorithm
-FUNCS += functions/gnutls_openpgp_privkey_get_pk_algorithm.short
-FUNCS += functions/gnutls_openpgp_privkey_get_preferred_key_id
-FUNCS += functions/gnutls_openpgp_privkey_get_preferred_key_id.short
-FUNCS += functions/gnutls_openpgp_privkey_get_revoked_status
-FUNCS += functions/gnutls_openpgp_privkey_get_revoked_status.short
-FUNCS += functions/gnutls_openpgp_privkey_get_subkey_count
-FUNCS += functions/gnutls_openpgp_privkey_get_subkey_count.short
-FUNCS += functions/gnutls_openpgp_privkey_get_subkey_creation_time
-FUNCS += functions/gnutls_openpgp_privkey_get_subkey_creation_time.short
-FUNCS += functions/gnutls_openpgp_privkey_get_subkey_expiration_time
-FUNCS += functions/gnutls_openpgp_privkey_get_subkey_expiration_time.short
-FUNCS += functions/gnutls_openpgp_privkey_get_subkey_fingerprint
-FUNCS += functions/gnutls_openpgp_privkey_get_subkey_fingerprint.short
-FUNCS += functions/gnutls_openpgp_privkey_get_subkey_id
-FUNCS += functions/gnutls_openpgp_privkey_get_subkey_id.short
-FUNCS += functions/gnutls_openpgp_privkey_get_subkey_idx
-FUNCS += functions/gnutls_openpgp_privkey_get_subkey_idx.short
-FUNCS += functions/gnutls_openpgp_privkey_get_subkey_pk_algorithm
-FUNCS += functions/gnutls_openpgp_privkey_get_subkey_pk_algorithm.short
-FUNCS += functions/gnutls_openpgp_privkey_get_subkey_revoked_status
-FUNCS += functions/gnutls_openpgp_privkey_get_subkey_revoked_status.short
-FUNCS += functions/gnutls_openpgp_privkey_import
-FUNCS += functions/gnutls_openpgp_privkey_import.short
-FUNCS += functions/gnutls_openpgp_privkey_init
-FUNCS += functions/gnutls_openpgp_privkey_init.short
-FUNCS += functions/gnutls_openpgp_privkey_sec_param
-FUNCS += functions/gnutls_openpgp_privkey_sec_param.short
-FUNCS += functions/gnutls_openpgp_privkey_set_preferred_key_id
-FUNCS += functions/gnutls_openpgp_privkey_set_preferred_key_id.short
FUNCS += functions/gnutls_openpgp_privkey_sign_hash
FUNCS += functions/gnutls_openpgp_privkey_sign_hash.short
FUNCS += functions/gnutls_openpgp_send_cert
FUNCS += functions/gnutls_openpgp_send_cert.short
-FUNCS += functions/gnutls_openpgp_set_recv_key_function
-FUNCS += functions/gnutls_openpgp_set_recv_key_function.short
FUNCS += functions/gnutls_packet_deinit
FUNCS += functions/gnutls_packet_deinit.short
FUNCS += functions/gnutls_packet_get