summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--tests/cert-tests/Makefile.am2
-rw-r--r--tests/cert-tests/data/openssl.p12bin0 -> 3669 bytes
-rwxr-xr-xtests/cert-tests/pkcs122
3 files changed, 2 insertions, 2 deletions
diff --git a/tests/cert-tests/Makefile.am b/tests/cert-tests/Makefile.am
index 89b8fcc235..a3160ffcb7 100644
--- a/tests/cert-tests/Makefile.am
+++ b/tests/cert-tests/Makefile.am
@@ -61,7 +61,7 @@ EXTRA_DIST = data/ca-no-pathlen.pem data/no-ca-or-pathlen.pem data/aki-cert.pem
data/selfsigs/alice.pub data/key-utf8-1.p12 data/key-utf8-2.p12 \
data/code-signing-ca.pem data/code-signing-cert.pem data/multi-value-dn.pem \
data/pkcs7-cat-ca.pem data/pkcs7-cat.p7 data/openssl.p7b data/openssl.p7b.out \
- data/openssl-keyid.p7b data/openssl-keyid.p7b.out
+ data/openssl-keyid.p7b data/openssl-keyid.p7b.out data/openssl.p12
dist_check_SCRIPTS = pathlen aki certtool invalid-sig email \
pkcs7 pkcs7-broken-sigs privkey-import name-constraints certtool-long-cn crl provable-privkey \
diff --git a/tests/cert-tests/data/openssl.p12 b/tests/cert-tests/data/openssl.p12
new file mode 100644
index 0000000000..b7915882a6
--- /dev/null
+++ b/tests/cert-tests/data/openssl.p12
Binary files differ
diff --git a/tests/cert-tests/pkcs12 b/tests/cert-tests/pkcs12
index c52b09b06c..bd71ded94d 100755
--- a/tests/cert-tests/pkcs12
+++ b/tests/cert-tests/pkcs12
@@ -37,7 +37,7 @@ TMPFILE_PEM=pkcs12.$$.pem.tmp
DEBUG="1"
ret=0
-for p12 in "client.p12 foobar" "noclient.p12" "unclient.p12" "pkcs12_2certs.p12"; do
+for p12 in "client.p12 foobar" "openssl.p12 CaudFocwijRupogDoicsApfiHadManUgNa" "noclient.p12" "unclient.p12" "pkcs12_2certs.p12"; do
set -- ${p12}
file="$1"
passwd="$2"