summaryrefslogtreecommitdiff
path: root/tests/suite/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2014-04-04 15:39:28 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2014-04-04 16:20:45 +0200
commitf63ae8935c3dbbd2c7d687f29e1dc5e7b415e7e7 (patch)
treeba0683e1aeca619b2d05565c5e301bf0ba182bb2 /tests/suite/Makefile.am
parent81aec2df8679a0ca6081653cd6db0dbb3a488aac (diff)
downloadgnutls-f63ae8935c3dbbd2c7d687f29e1dc5e7b415e7e7.tar.gz
Perform the certificate verification tests in PKCS #11-based verification using softhsm.
Diffstat (limited to 'tests/suite/Makefile.am')
-rw-r--r--tests/suite/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/suite/Makefile.am b/tests/suite/Makefile.am
index f9f23c5482..fd199531ae 100644
--- a/tests/suite/Makefile.am
+++ b/tests/suite/Makefile.am
@@ -30,6 +30,7 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/tests/suite/ecore/src/include \
-I$(top_srcdir)/tests/suite/ecore/src/lib
+check_PROGRAMS =
AM_LDFLAGS = -no-install
LDADD = ../../lib/libgnutls.la \
../../gl/libgnu.la \
@@ -86,6 +87,11 @@ nodist_check_SCRIPTS = eagain testsrn testcompat chain invalid-cert testrandom
TESTS = ciphersuite/test-ciphersuites.sh eagain testsrn testcompat chain invalid-cert
+if ENABLE_PKCS11
+check_PROGRAMS += pkcs11-chainverify
+TESTS += pkcs11-chainverify
+endif
+
TESTS_ENVIRONMENT = EXEEXT=$(EXEEXT) \
LC_ALL="C" \
top_builddir="$(top_builddir)" \