summaryrefslogtreecommitdiff
path: root/tests/slow/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2013-11-08 16:48:32 +0100
committerNikos Mavrogiannopoulos <nmav@redhat.com>2013-11-27 11:41:05 +0100
commit9715e8597da2bc4e7fb6e42f62039a7024a5418b (patch)
tree15fb089b0ec475d4f568cdc3f9dd01eeac078eba /tests/slow/Makefile.am
parent76aa381dba35527cafd387a0046eca97a25ef3c4 (diff)
downloadgnutls-9715e8597da2bc4e7fb6e42f62039a7024a5418b.tar.gz
Self checks are conditionally included in the library.
Diffstat (limited to 'tests/slow/Makefile.am')
-rw-r--r--tests/slow/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/slow/Makefile.am b/tests/slow/Makefile.am
index 265588434b..0e4b382a67 100644
--- a/tests/slow/Makefile.am
+++ b/tests/slow/Makefile.am
@@ -24,7 +24,13 @@ AM_CPPFLAGS = -I$(top_srcdir)/lib/includes \
AM_LDFLAGS = -no-install
LDADD = ../libutils.la \
- ../../lib/libgnutls.la $(LTLIBGCRYPT) $(LIBSOCKET)
+ $(top_builddir)/lib/libgnutls.la $(LTLIBGCRYPT) $(LIBSOCKET)
+
+if !ENABLE_SELF_CHECKS
+cipher_test_CPPFLAGS = $(AM_CPPFLAGS) -I$(top_builddir)/lib/ -I$(top_builddir)/gl/
+else
+cipher_test_CPPFLAGS = $(AM_CPPFLAGS)
+endif
ctests = gendh keygen cipher-test