summaryrefslogtreecommitdiff
path: root/tests/cert-tests/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2016-03-31 17:15:34 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2016-03-31 17:15:37 +0200
commitf6c92f8a6d974066a6f66f5358ecf815b7747a5e (patch)
tree6f7d6981b57e09825fa1887fcaeca07b26605945 /tests/cert-tests/Makefile.am
parent8ee8a53bef77be018c4eeb261309846f261a35c8 (diff)
downloadgnutls-f6c92f8a6d974066a6f66f5358ecf815b7747a5e.tar.gz
tests: added PKCS #7 signing/verification test with broken sigs (MD5)
This tests whether we can sign structures using broken algorithms (MD5), and verify structures signed with broken algoritms if --verify-allow-broken is given to certtool.
Diffstat (limited to 'tests/cert-tests/Makefile.am')
-rw-r--r--tests/cert-tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/cert-tests/Makefile.am b/tests/cert-tests/Makefile.am
index f6da78369b..ef86a5c6d9 100644
--- a/tests/cert-tests/Makefile.am
+++ b/tests/cert-tests/Makefile.am
@@ -42,7 +42,7 @@ EXTRA_DIST = ca-no-pathlen.pem no-ca-or-pathlen.pem aki-cert.pem \
template-ecdsa-sha3-512.pem name-constraints-ip2.pem
dist_check_SCRIPTS = pathlen aki certtool invalid-sig email \
- pkcs7 privkey-import name-constraints certtool-long-cn crl provable-privkey
+ pkcs7 pkcs7-broken-sigs privkey-import name-constraints certtool-long-cn crl provable-privkey
if !HAVE_BUGGY_LIBIDN
dist_check_SCRIPTS += certtool-utf8