summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2019-01-08 12:26:19 +0100
committerNikos Mavrogiannopoulos <nmav@redhat.com>2019-01-09 16:09:58 +0100
commitb47bdcd966d7d56db1f0d883675b210bbc67061b (patch)
tree9adac32a345a6ab07363eb890e191b8c2fc99cb0 /tests/Makefile.am
parent42d5844c33aa27fd3eb107c3bdbe45e7c7d0df7b (diff)
downloadgnutls-b47bdcd966d7d56db1f0d883675b210bbc67061b.tar.gz
When sending no extensions do not include a zero length
According to RFC5246: The presence of extensions can be detected by determining whether there are bytes following the compression_method field at the end of the ServerHello. and as such we correct our behavior to not send the zero length bytes. This was our behavior in 3.5.x and 3.3.x branch, and thus this corrects a regression of gnutls with these branches. Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com> Signed-off-by: David Woodhouse <dwmw2@infradead.org>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ad496b04a7..56149cce5e 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -200,7 +200,7 @@ ctests += mini-record-2 simple gnutls_hmac_fast set_pkcs12_cred cert certuniquei
set_known_dh_params_anon set_known_dh_params_psk session-tickets-ok \
session-tickets-missing set_x509_key_file_legacy status-request-ext \
gnutls_x509_crt_sign gnutls_x509_crq_sign dtls-repro-20170915 \
- rng-no-onload dtls1-2-mtu-check crl_apis cert_verify_inv_utf8 \
+ rng-no-onload dtls1-2-mtu-check crl_apis cert_verify_inv_utf8 no-extensions \
hostname-check-utf8 pkcs8-key-decode-encrypted priority-mix pkcs7 \
send-data-before-handshake recv-data-before-handshake crt_inv_write \
x509sign-verify-error rng-op-nonce rng-op-random rng-op-key x509-dn-decode-compat \