summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@redhat.com>2019-04-04 16:51:28 +0200
committerDaiki Ueno <dueno@redhat.com>2019-04-07 08:22:01 +0200
commit456170176a95d9c0855c872748c1295e805961a2 (patch)
tree1031fc16042f0023c1d610632277d145cf153180 /tests/Makefile.am
parentbaccc00085062f712c811bee925c86709551f422 (diff)
downloadgnutls-456170176a95d9c0855c872748c1295e805961a2.tar.gz
tests: add post-handshake auth test using PKCS#11 token
This adds a test that exercise the client's auth rejection logic, using the RSA-PSS disabled PKCS #11 token. Signed-off-by: Daiki Ueno <dueno@redhat.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 37e33c0efe..96e10bfc5b 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -450,6 +450,14 @@ tls13_anti_replay_CPPFLAGS = $(AM_CPPFLAGS) \
-I$(top_builddir)/gl \
$(NETTLE_CFLAGS)
+if ENABLE_PKCS11
+if !WINDOWS
+ctests += tls13/post-handshake-with-cert-pkcs11
+tls13_post_handshake_with_cert_pkcs11_DEPENDENCIES = libpkcs11mock2.la libutils.la
+tls13_post_handshake_with_cert_pkcs11_LDADD = $(LDADD) $(LIBDL)
+endif
+endif
+
dist_check_SCRIPTS = rfc2253-escape-test rsa-md5-collision/rsa-md5-collision.sh systemkey.sh
if !WINDOWS