summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2016-10-22 03:28:14 +0300
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2016-10-25 14:42:37 +0300
commit23fe17ceb8e1d1d4c2a72d553a70d104b0591479 (patch)
tree79a0d4be1b9f6ef62eed4a44205ff23dff3022a5 /tests/Makefile.am
parentd96257147860ef1e3b48023352b62c165ab8b89d (diff)
downloadgnutls-23fe17ceb8e1d1d4c2a72d553a70d104b0591479.tar.gz
Fix compilation of tests if nettle is not installed in standard path
Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a0a85afe5e..733ece75be 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -208,6 +208,9 @@ if ENABLE_DANE
ctests += dane
endif
+rsa_illegal_import_CPPFLAGS = $(AM_CPPFLAGS) $(NETTLE_CFLAGS)
+
+mini_alignment_CPPFLAGS = $(AM_CPPFLAGS) $(NETTLE_CFLAGS)
mini_alignment_LDADD = $(LDADD) $(NETTLE_LIBS)
if ENABLE_OPENSSL
@@ -232,6 +235,7 @@ endif
endif
gc_CPPFLAGS = $(CPPFLAGS) \
+ $(NETTLE_CFLAGS) \
-I$(top_srcdir)/lib/includes \
-I$(top_builddir)/lib/includes \
-I$(top_srcdir)/lib/minitasn1 \
@@ -240,6 +244,7 @@ gc_CPPFLAGS = $(CPPFLAGS) \
-I$(top_builddir)/gl
mpi_CPPFLAGS = $(CPPFLAGS) \
+ $(NETTLE_CFLAGS) \
-I$(top_srcdir)/lib/includes \
-I$(top_builddir)/lib/includes \
-I$(top_srcdir)/lib/minitasn1 \
@@ -248,6 +253,7 @@ mpi_CPPFLAGS = $(CPPFLAGS) \
-I$(top_builddir)/gl
atfork_CPPFLAGS = $(CPPFLAGS) \
+ $(NETTLE_CFLAGS) \
-I$(top_srcdir)/lib/includes \
-I$(top_builddir)/lib/includes \
-I$(top_srcdir)/lib/minitasn1 \
@@ -256,6 +262,7 @@ atfork_CPPFLAGS = $(CPPFLAGS) \
-I$(top_builddir)/gl
pkcs12_s2k_CPPFLAGS = $(CPPFLAGS) \
+ $(NETTLE_CFLAGS) \
-I$(top_srcdir)/lib/includes \
-I$(top_builddir)/lib/includes \
-I$(top_srcdir)/lib/minitasn1 \
@@ -264,6 +271,7 @@ pkcs12_s2k_CPPFLAGS = $(CPPFLAGS) \
-I$(top_builddir)/gl
name_constraints_merge_CPPFLAGS = $(CPPFLAGS) \
+ $(NETTLE_CFLAGS) \
-I$(top_srcdir)/lib/includes \
-I$(top_builddir)/lib/includes \
-I$(top_srcdir)/lib/minitasn1 \