summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2018-01-10 15:35:36 +0100
committerNikos Mavrogiannopoulos <nmav@redhat.com>2018-01-16 08:54:22 +0100
commite2a8819c0c60388235aaf94e255e83f9f1a3dd53 (patch)
treee0345c1bc656b01c440a282a26561486fd1befeb /tests/Makefile.am
parenta0ec827a3c7ff6e4ab9d695c92366ad83bf4348e (diff)
downloadgnutls-e2a8819c0c60388235aaf94e255e83f9f1a3dd53.tar.gz
tests: added unit test for _gnutls_record_overhead()
Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c389046eb2..95f7f8db96 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -169,8 +169,9 @@ endif
if HAVE_CMOCKA
CMOCKA_LDADD = $(COMMON_LDADD) $(CMOCKA_LIBS)
ctests += dtls-sliding-window ip-utils name-constraints-ip conv-utf8 str-unicode str-idna \
- tls10-prf tls12-prf
+ tls10-prf tls12-prf gnutls_record_overhead
+gnutls_record_overhead_LDADD = $(CMOCKA_LDADD)
dtls_sliding_window_LDADD = $(CMOCKA_LDADD)
ip_utils_LDADD = $(CMOCKA_LDADD)
name_constraints_ip_LDADD = $(CMOCKA_LDADD)
@@ -180,6 +181,11 @@ str_idna_LDADD = $(CMOCKA_LDADD)
tls10_prf_LDADD = $(CMOCKA_LDADD)
tls12_prf_LDADD = $(CMOCKA_LDADD)
+gnutls_record_overhead_CPPFLAGS = $(AM_CPPFLAGS) \
+ -I$(top_srcdir)/gl \
+ -I$(top_builddir)/gl \
+ $(NETTLE_CFLAGS)
+
endif
mini_dtls_pthread_LDADD = $(LDADD) -lpthread