summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2018-03-19 18:29:23 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2018-03-19 19:54:29 +0100
commit100afec741777ee13b057577f36a685752ab5287 (patch)
tree6c4e47bbf8653b5fc6c689d1bcc650df02ec97ec /tests/Makefile.am
parent16e63cbd685b328b0602ac95494feb8711f4df8e (diff)
downloadgnutls-100afec741777ee13b057577f36a685752ab5287.tar.gz
tests: testpkcs11.sh was moved to the main tests
Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 15ce1908ff..18814bf3f5 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -64,7 +64,10 @@ EXTRA_DIST = suppressions.valgrind eagain-common.h cert-common.h test-chains.h \
data/listings-SSL3.0-TLS1.1 p11-kit-trust-data/Example_Root_CA.p11-kit server-kx-neg-common.c \
p11-kit-trust-data/Example_Root_CA.pem data/test1.cat data/test2.cat \
data/test1.cat.data data/test2.cat.data data/test1.cat.out data/test2.cat.out \
- data/pkcs7-cat-ca.pem data/long.crl data/long.pem
+ data/pkcs7-cat-ca.pem data/long.crl data/long.pem \
+ testpkcs11.pkcs15 testpkcs11.softhsm testpkcs11.sc-hsm testpkcs11-certs/ca.crt testpkcs11-certs/ca-tmpl \
+ testpkcs11-certs/client.key testpkcs11-certs/server.crt testpkcs11-certs/server-tmpl \
+ testpkcs11-certs/ca.key testpkcs11-certs/client.crt testpkcs11-certs/client-tmpl testpkcs11-certs/server.key
AM_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
AM_CPPFLAGS = \
@@ -389,7 +392,7 @@ dist_check_SCRIPTS += fastopen.sh pkgconfig.sh starttls.sh starttls-ftp.sh start
dist_check_SCRIPTS += gnutls-cli-self-signed.sh
if ENABLE_PKCS11
-dist_check_SCRIPTS += p11-kit-trust.sh
+dist_check_SCRIPTS += p11-kit-trust.sh testpkcs11.sh certtool-pkcs11.sh
if HAVE_PKCS11_TRUST_STORE
if P11KIT_0_23_10_API