summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@redhat.com>2019-04-29 19:03:55 +0200
committerDaiki Ueno <dueno@redhat.com>2019-05-20 15:29:19 +0200
commit86d5c56950489bc8469f73602d793ef48af6419a (patch)
treeebbcc93320c8379ac1afc854dabce777753ab5d1 /tests/Makefile.am
parent13cc2e983446f578fa7aee7ef00231c35ddbf6e7 (diff)
downloadgnutls-86d5c56950489bc8469f73602d793ef48af6419a.tar.gz
server auth: disable TLS 1.3 if no signature algorithm is usable
This is a server side counterpart of 005a4d04145707daad9588acedfdb5f6cd97c80c. Instead of signalling an error when no algorithm is usable in TLS 1.3, it downgrades the session to TLS 1.2 with a warning. Signed-off-by: Daiki Ueno <dueno@redhat.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index eb65e94858..9643a93265 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -453,9 +453,11 @@ tls13_anti_replay_CPPFLAGS = $(AM_CPPFLAGS) \
if ENABLE_PKCS11
if !WINDOWS
-ctests += tls13/post-handshake-with-cert-pkcs11
+ctests += tls13/post-handshake-with-cert-pkcs11 pkcs11/tls-neg-pkcs11-no-key
tls13_post_handshake_with_cert_pkcs11_DEPENDENCIES = libpkcs11mock2.la libutils.la
tls13_post_handshake_with_cert_pkcs11_LDADD = $(LDADD) $(LIBDL)
+pkcs11_tls_neg_pkcs11_no_key_DEPENDENCIES = libpkcs11mock2.la libutils.la
+pkcs11_tls_neg_pkcs11_no_key_LDADD = $(LDADD) $(LIBDL)
endif
endif