summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@redhat.com>2018-10-19 17:52:48 +0200
committerDaiki Ueno <dueno@redhat.com>2018-11-12 14:08:45 +0100
commit79f2f1cf5b91491be5f0e3486c416594ec522b25 (patch)
treeeec06e9a96e5c64449e3469c477fc1d332953d12 /tests/Makefile.am
parent8ada9c280c9044644dfad1f234e3da32f0df86a0 (diff)
downloadgnutls-79f2f1cf5b91491be5f0e3486c416594ec522b25.tar.gz
TLS 1.3: implement anti-replay measure using ClientHello recording
This implements ClientHello recording outlined in section 8.2 of RFC 8446. Signed-off-by: Daiki Ueno <dueno@redhat.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index b3fee01e00..1ccba11028 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -109,7 +109,8 @@ ctests = tls13/supported_versions tls13/tls12-no-tls13-exts \
tls13/cookie tls13/key_share tls13/prf tls13/post-handshake-with-cert-ticket \
tls12-rollback-detection tls11-rollback-detection \
tls12-check-rollback-val tls11-check-rollback-val tls13/hello_random_value \
- tls13/post-handshake-with-psk tls13/post-handshake-with-cert-auto
+ tls13/post-handshake-with-psk tls13/post-handshake-with-cert-auto \
+ tls13/anti_replay
ctests += tls13/hello_retry_request
@@ -425,6 +426,16 @@ name_constraints_merge_CPPFLAGS = $(AM_CPPFLAGS) \
-I$(top_builddir)/gl \
$(NETTLE_CFLAGS)
+murmur3_CPPFLAGS = $(AM_CPPFLAGS) \
+ -I$(top_srcdir)/gl \
+ -I$(top_builddir)/gl \
+ $(NETTLE_CFLAGS)
+
+tls13_anti_replay_CPPFLAGS = $(AM_CPPFLAGS) \
+ -I$(top_srcdir)/gl \
+ -I$(top_builddir)/gl \
+ $(NETTLE_CFLAGS)
+
dist_check_SCRIPTS = rfc2253-escape-test rsa-md5-collision/rsa-md5-collision.sh systemkey.sh
if !WINDOWS