summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2020-03-29 21:30:37 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2020-03-30 08:49:17 +0200
commitac2f71b892d13a7ab4cc39086eef179042c7e23c (patch)
tree115d010b83473d10dcee692fb6cbf7e06a20d0b1 /tests/Makefile.am
parent90a8f888b675c5d47d762a84bcd03266fbb5dc32 (diff)
downloadgnutls-ac2f71b892d13a7ab4cc39086eef179042c7e23c.tar.gz
tests: added check for random value of client and server hello in TLS
This creates a tests that checks whether the TLS client and server hello have sufficient non-zero bytes. Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ee6c601a45..b5a3eb673e 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -218,7 +218,7 @@ ctests += mini-record-2 simple gnutls_hmac_fast set_pkcs12_cred cert certuniquei
sign-verify-newapi sign-verify-deterministic iov aead-cipher-vec \
tls13-without-timeout-func buffer status-request-revoked \
set_x509_ocsp_multi_cli kdf-api keylog-func \
- dtls_hello_random_value
+ dtls_hello_random_value tls_hello_random_value
if HAVE_SECCOMP_TESTS
ctests += dtls-with-seccomp tls-with-seccomp dtls-client-with-seccomp tls-client-with-seccomp