summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <ueno@gnu.org>2019-05-22 10:16:52 +0000
committerDaiki Ueno <ueno@gnu.org>2019-05-22 10:16:52 +0000
commit825d455c2b232bb5444393a6411878d659d249ff (patch)
treee0f537088af846568bb6bfa3a061a2117ed869cd /tests/Makefile.am
parent27ec82e781b3960693cd4550440ab7c1664553b8 (diff)
parent0caf5b6922bd443bcf3eb1398a16c9d381fba86f (diff)
downloadgnutls-825d455c2b232bb5444393a6411878d659d249ff.tar.gz
Merge branch 'tmp-privkey-tls13' into 'master'
server auth: disable TLS 1.3 if no signature algorithm is usable Closes #731 See merge request gnutls/gnutls!987
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f3602e7009..05c0a61b79 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -453,9 +453,11 @@ tls13_anti_replay_CPPFLAGS = $(AM_CPPFLAGS) \
if ENABLE_PKCS11
if !WINDOWS
-ctests += tls13/post-handshake-with-cert-pkcs11
+ctests += tls13/post-handshake-with-cert-pkcs11 pkcs11/tls-neg-pkcs11-no-key
tls13_post_handshake_with_cert_pkcs11_DEPENDENCIES = libpkcs11mock2.la libutils.la
tls13_post_handshake_with_cert_pkcs11_LDADD = $(LDADD) $(LIBDL)
+pkcs11_tls_neg_pkcs11_no_key_DEPENDENCIES = libpkcs11mock2.la libutils.la
+pkcs11_tls_neg_pkcs11_no_key_LDADD = $(LDADD) $(LIBDL)
endif
endif