summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2016-06-03 14:24:32 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2016-06-03 14:55:53 +0200
commit90c63497b19ffa56b37ace62d6fa89b1c021a5ae (patch)
tree1d7065cfeeab343948cf3a43417ea0a5b9272c20 /tests/Makefile.am
parent8bf344e46e0d2dea3561395533e20a0e32a84931 (diff)
downloadgnutls-90c63497b19ffa56b37ace62d6fa89b1c021a5ae.tar.gz
tests: check gnutls_pkcs11_obj_list_import_url4() with GNUTLS_PKCS11_OBJ_FLAG_OVERWRITE_TRUSTMOD_EXT
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 840a3f370b..721324e9d4 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -107,7 +107,7 @@ ctests = mini-record-2 simple gc set_pkcs12_cred certder certuniqueid \
set_x509_key_file_der set_x509_pkcs12_key crt_apis tls1.2-cert-key-exchange \
tls1.1-cert-key-exchange tls1.0-cert-key-exchange ssl3.0-cert-key-exchange \
dtls1.2-cert-key-exchange dtls1.0-cert-key-exchange x509-cert-callback-legacy \
- keylog-env ssl2-hello tlsfeature-ext
+ keylog-env ssl2-hello tlsfeature-ext pkcs11-cert-import-url4-exts
if HAVE_SECCOMP_TESTS
ctests += dtls-with-seccomp tls-with-seccomp dtls-client-with-seccomp tls-client-with-seccomp
@@ -140,6 +140,9 @@ libpkcs11mock1_la_LDFLAGS = -shared -rpath $(pkglibdir) -module -no-undefined -a
pkcs11_cert_import_url_exts_SOURCES = pkcs11/pkcs11-cert-import-url-exts.c
pkcs11_cert_import_url_exts_DEPENDENCIES = libpkcs11mock1.la libutils.la
+pkcs11_cert_import_url4_exts_SOURCES = pkcs11/pkcs11-cert-import-url4-exts.c
+pkcs11_cert_import_url4_exts_DEPENDENCIES = libpkcs11mock1.la libutils.la
+
pkcs11_get_exts_SOURCES = pkcs11/pkcs11-get-exts.c
pkcs11_get_exts_DEPENDENCIES = libpkcs11mock1.la libutils.la