summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2018-04-17 09:52:01 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2018-04-18 11:21:25 +0200
commitdfc40f1250228278ec4c0d1d5bc29d396605b535 (patch)
treecad0e564b47e9ef72d02ad3b15295a1855a76395 /tests/Makefile.am
parent21c56085c53e0aedd6379764167c2651f3045c04 (diff)
downloadgnutls-dfc40f1250228278ec4c0d1d5bc29d396605b535.tar.gz
tests: added reproducers for receiving app data when rehandshake is expected
Relates: #426 Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 60cebadaec..88f56455c8 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -132,7 +132,7 @@ ctests += mini-record-2 simple gnutls_hmac_fast set_pkcs12_cred cert certuniquei
tls12-cipher-neg tls11-cipher-neg tls10-cipher-neg ssl30-cipher-neg \
crq_apis init_roundtrip pkcs12_s2k_pem dn2 tls12-rehandshake-cert-3 \
nul-in-x509-names x509_altname pkcs12_encode mini-x509 \
- tls12-rehandshake-cert rng-fork mini-eagain-dtls resume-dtls \
+ rng-fork mini-eagain-dtls resume-dtls \
tls13-rehandshake-cert gnutls_ext_raw_parse \
x509cert x509cert-tl infoaccess mini-dtls-hello-verify sign-verify-ed25519-rfc8080 \
trustdb-tofu dtls-rehandshake-anon mini-alpn mini-dtls-large \
@@ -201,7 +201,7 @@ endif
if HAVE_CMOCKA
CMOCKA_LDADD = $(COMMON_LDADD) $(CMOCKA_LIBS)
ctests += dtls-sliding-window ip-utils name-constraints-ip conv-utf8 str-unicode str-idna \
- tls10-prf tls12-prf gnutls_record_overhead eagain
+ tls10-prf tls12-prf gnutls_record_overhead eagain tls12-rehandshake-cert
gnutls_record_overhead_LDADD = $(CMOCKA_LDADD)
dtls_sliding_window_LDADD = $(CMOCKA_LDADD)
@@ -213,6 +213,7 @@ str_idna_LDADD = $(CMOCKA_LDADD)
tls10_prf_LDADD = $(CMOCKA_LDADD)
tls12_prf_LDADD = $(CMOCKA_LDADD)
eagain_LDADD = $(CMOCKA_LDADD)
+tls12_rehandshake_cert_LDADD = $(CMOCKA_LDADD)
gnutls_record_overhead_CPPFLAGS = $(AM_CPPFLAGS) \
-I$(top_srcdir)/gl \