summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2018-05-15 11:22:24 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2018-05-26 04:12:04 +0000
commita70b637f758f69889a5a6678a907a1fbe50d2424 (patch)
tree87d5cd8d9793d98a19371b0a826171a2c5ace522 /tests/Makefile.am
parent5f2c52311fc63040976ee9844db9f626561e2747 (diff)
downloadgnutls-a70b637f758f69889a5a6678a907a1fbe50d2424.tar.gz
tests: added main use-case test for gnutls_session_ticket_send()
It verifies whether a server can use gnutls_session_ticket_send() to send a ticket after re-authentication, and whether a client can receive that ticket and re-authenticate with it, while its certificate is made available to server. Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 978c7b52e4..e095e36cbc 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -104,7 +104,7 @@ libutils_la_LIBADD = ../lib/libgnutls.la
indirect_tests =
ctests = tls13/supported_versions tls13/tls12-no-tls13-exts \
tls13/post-handshake-with-cert tls13/post-handshake-without-cert \
- tls13/cookie tls13/key_share tls13/prf \
+ tls13/cookie tls13/key_share tls13/prf tls13/post-handshake-with-cert-ticket \
tls12-rollback-detection tls11-rollback-detection \
tls12-check-rollback-val tls11-check-rollback-val tls13/hello_random_value