summaryrefslogtreecommitdiff
path: root/libextra/Makefile.am
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2009-04-20 18:15:24 +0200
committerSimon Josefsson <simon@josefsson.org>2009-04-20 18:15:24 +0200
commit0a0c5f2a8201668b4a123e5b9128b0c616f0004f (patch)
tree03de6b0b4011f6958eab661cac9e797d7ea22831 /libextra/Makefile.am
parentc74bd35f387326ade04f106b36d9155393dc5439 (diff)
downloadgnutls-0a0c5f2a8201668b4a123e5b9128b0c616f0004f.tar.gz
Improve version scripts. Limit exported symbols on systems without linker script.
Diffstat (limited to 'libextra/Makefile.am')
-rw-r--r--libextra/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/libextra/Makefile.am b/libextra/Makefile.am
index 1faa5e55fe..07227673b3 100644
--- a/libextra/Makefile.am
+++ b/libextra/Makefile.am
@@ -50,7 +50,7 @@ defexec_DATA =
lib_LTLIBRARIES = libgnutls-extra.la
-libgnutls_extra_la_SOURCES = gnutls_extra.c fipsmd5.c
+libgnutls_extra_la_SOURCES = libgnutls-extra.map gnutls_extra.c fipsmd5.c
libgnutls_openssl_la_LDFLAGS = -no-undefined
@@ -103,14 +103,14 @@ libgnutls_extra_la_LDFLAGS += \
-version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
$(LZO_LIBS)
-libgnutls_extra_la_SOURCES += libgnutls-extra.vers
-
libgnutls_extra_la_LIBADD += ../lib/gl/liblgnu.la gl/libxgnu.la \
../lib/libgnutls.la
if HAVE_LD_VERSION_SCRIPT
libgnutls_extra_la_LDFLAGS += \
- -Wl,--version-script=$(srcdir)/libgnutls-extra.vers
+ -Wl,--version-script=$(srcdir)/libgnutls-extra.map
+else
+libgnutls_extra_la_LDFLAGS += -export-symbols-regex '^(gnutls_).*'
endif
gnutls-extra-api.texi: gnutls_extra.c