summaryrefslogtreecommitdiff
path: root/lib/x509/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2017-07-15 17:54:01 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2017-07-17 15:45:03 +0200
commit4bf14c5d081369a5cfcaf3743a7dc6f0cdada7d3 (patch)
treec3c12f00076532837626e0eb7c5ff4b3e84905f0 /lib/x509/Makefile.am
parentb18d604b592d0069a8fe1f0b7e8d639cab6fa2cc (diff)
downloadgnutls-4bf14c5d081369a5cfcaf3743a7dc6f0cdada7d3.tar.gz
supported_exts.h: make sure that the generated function is static
That avoids compiler warnings due to missing prototype. Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Diffstat (limited to 'lib/x509/Makefile.am')
-rw-r--r--lib/x509/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/x509/Makefile.am b/lib/x509/Makefile.am
index 946ed4afaa..8bf2e04b8b 100644
--- a/lib/x509/Makefile.am
+++ b/lib/x509/Makefile.am
@@ -82,4 +82,4 @@ libgnutls_x509_la_SOURCES += ocsp.c ocsp_output.c
endif
supported_exts.h: $(srcdir)/supported_exts.gperf
- -gperf --global-table -t $^ > $@-tmp && mv $@-tmp $@
+ -gperf --global-table -t $^ > $@-tmp && sed -i 's/^const struct supported_exts_st \*/static const struct supported_exts_st \*/' $@-tmp && mv $@-tmp $@