summaryrefslogtreecommitdiff
path: root/lib/nettle/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2013-11-25 13:46:22 +0100
committerNikos Mavrogiannopoulos <nmav@redhat.com>2013-11-27 11:41:44 +0100
commit1421e31ffb12ad4c877ee62223bfdaeb0d6f4a62 (patch)
tree6187c635844319739998e4032e684156e9869576 /lib/nettle/Makefile.am
parentc3e655723f85a3e57f97d7224f88a832f8414adf (diff)
downloadgnutls-1421e31ffb12ad4c877ee62223bfdaeb0d6f4a62.tar.gz
Added DRBG submitted to nettle in gnutls.
Diffstat (limited to 'lib/nettle/Makefile.am')
-rw-r--r--lib/nettle/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/lib/nettle/Makefile.am b/lib/nettle/Makefile.am
index b93a2bbc41..52b3489bd3 100644
--- a/lib/nettle/Makefile.am
+++ b/lib/nettle/Makefile.am
@@ -24,6 +24,7 @@ AM_CFLAGS = $(WERROR_CFLAGS) $(WSTACK_CFLAGS) $(WARN_CFLAGS) \
$(GMP_CFLAGS)
AM_CPPFLAGS = \
+ -I$(srcdir)/int \
-I$(srcdir)/../../gl \
-I$(builddir)/../../gl \
-I$(srcdir)/../includes \
@@ -38,10 +39,11 @@ endif
noinst_LTLIBRARIES = libcrypto.la
libcrypto_la_SOURCES = pk.c mpi.c mac.c cipher.c init.c egd.c egd.h \
- gnettle.h gcm-camellia.h gcm-camellia.c rnd-common.h rnd-common.c
+ gnettle.h rnd-common.h rnd-common.c \
+ int/gcm-camellia.h int/gcm-camellia.c
if ENABLE_FIPS140
-libcrypto_la_SOURCES += rnd-fips.c
+libcrypto_la_SOURCES += rnd-fips.c int/drbg-aes.c int/drbg-aes.h int/drbg-aes-self-test.c
else
libcrypto_la_SOURCES += rnd.c
endif