summaryrefslogtreecommitdiff
path: root/lib/ext/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2014-11-03 14:23:48 +0100
committerNikos Mavrogiannopoulos <nmav@redhat.com>2014-11-03 17:09:01 +0100
commite93cef18471962b001dac0f792cb569f1a4cde58 (patch)
treea8e33fc6c302a7126fc177d1f4a8f0e16fabf52b /lib/ext/Makefile.am
parente29d027872fb61a6e7117d3b920626bbc638ac64 (diff)
downloadgnutls-e93cef18471962b001dac0f792cb569f1a4cde58.tar.gz
Added support for RFC7366 (encrypt then authenticate)
It implements a revised version of RFC7366, to avoid interoperability issues: http://www.ietf.org/mail-archive/web/tls/current/msg14349.html This is currently enabled by default, unless %NO_ETM, or %COMPAT is specified.
Diffstat (limited to 'lib/ext/Makefile.am')
-rw-r--r--lib/ext/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/ext/Makefile.am b/lib/ext/Makefile.am
index 9b7012bed2..04edf81b91 100644
--- a/lib/ext/Makefile.am
+++ b/lib/ext/Makefile.am
@@ -40,7 +40,7 @@ libgnutls_ext_la_SOURCES = max_record.c cert_type.c \
session_ticket.h signature.h safe_renegotiation.h \
session_ticket.c srp.c ecc.c ecc.h heartbeat.c heartbeat.h \
status_request.h status_request.c dumbfw.c dumbfw.h \
- ext_master_secret.c ext_master_secret.h
+ ext_master_secret.c ext_master_secret.h etm.h etm.c
if ENABLE_ALPN
libgnutls_ext_la_SOURCES += alpn.c alpn.h