summaryrefslogtreecommitdiff
path: root/lib/ext/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2012-12-18 12:04:27 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2013-01-02 22:00:50 +0100
commit7d3eed318b399a83ebc789467869383411378333 (patch)
tree375291ad79d9f41fc265c6bba4e79192a53663df /lib/ext/Makefile.am
parenta287a84d3b9065fef8a397580c7b79293e2ac167 (diff)
downloadgnutls-7d3eed318b399a83ebc789467869383411378333.tar.gz
Added a new record padding mechanism.
It is negotiated via an extension and record data are now formatted as: ciphered-struct { opaque pad<0..2^16-1> opaque content[TLSCompressed.length]; opaque MAC[CipherSpec.hash_size]; } The ciphered-struct size is always 0 modulo the block size in block ciphers to avoid any need for additional padding. Added extension to negotiate new record padding.
Diffstat (limited to 'lib/ext/Makefile.am')
-rw-r--r--lib/ext/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/ext/Makefile.am b/lib/ext/Makefile.am
index 1719fd75a4..604fce1034 100644
--- a/lib/ext/Makefile.am
+++ b/lib/ext/Makefile.am
@@ -39,7 +39,8 @@ libgnutls_ext_la_SOURCES = max_record.c cert_type.c \
max_record.h cert_type.h server_name.h srp.h \
session_ticket.h signature.h safe_renegotiation.h \
session_ticket.c srp.c ecc.c ecc.h heartbeat.c heartbeat.h \
- status_request.h status_request.c
+ status_request.h status_request.c new_record_padding.c \
+ new_record_padding.h
if ENABLE_DTLS_SRTP
libgnutls_ext_la_SOURCES += srtp.c srtp.h