summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2016-11-21 09:20:36 +0100
committerNikos Mavrogiannopoulos <nmav@redhat.com>2016-11-21 11:56:44 +0100
commit2d1285f14956a89c36219f34611f4c454197140f (patch)
treeb86f7ef54929a9f656b35409a5787e8a005f4e6e /lib/Makefile.am
parent36eb09b1dffd3bcf1fbea35daf87a667b40d7123 (diff)
downloadgnutls-2d1285f14956a89c36219f34611f4c454197140f.tar.gz
lib: added unistring sub-library
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 87d6b4ea73..a704b75541 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -51,6 +51,11 @@ SUBDIRS += openpgp
AM_CPPFLAGS += -I$(srcdir)/opencdk
endif
+if !HAVE_LIBUNISTRING
+SUBDIRS += unistring
+AM_CPPFLAGS += -I$(srcdir)/unistring/ -I$(builddir)/unistring/
+endif
+
if ENABLE_MINITASN1
AM_CPPFLAGS += -I$(srcdir)/minitasn1
endif
@@ -139,6 +144,8 @@ endif
if HAVE_LIBUNISTRING
thirdparty_libadd += $(LTLIBUNISTRING)
+else
+libgnutls_la_LIBADD += unistring/libunistring.la
endif
if ENABLE_NETTLE