summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2013-11-09 22:39:35 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2013-11-09 22:39:35 +0100
commit1ba8d9f5e50a07046d33a91b2aeae5af77fbaf58 (patch)
tree98040292a9656c0cabb9c6c77c776a545015e325 /lib/Makefile.am
parentcdfcdeb7e10efeedb0a6df0e879f2ac37da9c1b3 (diff)
downloadgnutls-1ba8d9f5e50a07046d33a91b2aeae5af77fbaf58.tar.gz
Improvements in PKCS #11 support.
Added gnutls_pkcs11_obj_export3 and gnutls_pkcs11_get_raw_issuer. The latter function allows to obtain the issuer of a certificate stored in a token. While traversing tokens, use the URL provided by the user, to avoid looking for objects in unrelated tokens.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 451185945f..af4ecbab9e 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -81,7 +81,8 @@ COBJECTS = gnutls_range.c gnutls_record.c \
crypto-backend.c verify-tofu.c pin.c tpm.c
if ENABLE_PKCS11
-COBJECTS += pkcs11.c pkcs11_privkey.c pkcs11_write.c pkcs11_secret.c
+COBJECTS += pkcs11.c pkcs11_privkey.c pkcs11_write.c pkcs11_secret.c \
+ pkcs11_int.c
endif
if ENABLE_NETTLE