summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2016-11-08 13:00:16 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2016-11-20 12:13:26 +0100
commitd753cfdcfc7e5342a38f27dde41cf8eb530b57a3 (patch)
treebccdff920f6b2682db3c279deac939f24d60330a /lib/Makefile.am
parente7785d07443a85ed85347c5413acd5194e026c9e (diff)
downloadgnutls-d753cfdcfc7e5342a38f27dde41cf8eb530b57a3.tar.gz
Added function for UTF-8 normalization based on RFC7613
This introduces gnutls_utf8_password_normalize() and a dependency on libunistring.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 94cf77107e..87d6b4ea73 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -74,7 +74,7 @@ COBJECTS = range.c record.c compress.c debug.c cipher.c \
mem.c fingerprint.c tls-sig.c ecc.c alert.c privkey_raw.c \
system/certs.c system/threads.c system/fastopen.c system/sockets.c \
system/inet_ntop.c system/iconv.c system/vasprintf.c vasprintf.h system.c \
- str.c state.c x509.c file.c supplemental.c \
+ str.c str-unicode.c state.c x509.c file.c supplemental.c \
random.c crypto-api.c privkey.c pcert.c pubkey.c locks.c dtls.c \
system_override.c crypto-backend.c verify-tofu.c pin.c tpm.c fips.c \
safe-memfuncs.c system/inet_pton.c atfork.c atfork.h randomart.c \
@@ -137,6 +137,10 @@ if HAVE_LIBIDN
thirdparty_libadd += $(LIBIDN_LIBS)
endif
+if HAVE_LIBUNISTRING
+thirdparty_libadd += $(LTLIBUNISTRING)
+endif
+
if ENABLE_NETTLE
libgnutls_la_LIBADD += accelerated/libaccelerated.la
endif