summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2016-04-29 10:23:45 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2016-04-29 10:30:03 +0200
commit9466b800f03a91ef1538dc6f562d58b4607b88e6 (patch)
tree88385ec566a43015cd9598feb7b2d4ad3022e815 /lib/Makefile.am
parent96cca97371237e31e6c98d705cd31f6b3b268d25 (diff)
downloadgnutls-9466b800f03a91ef1538dc6f562d58b4607b88e6.tar.gz
handshake: enhance same certificate checks to apply to PSK/SRP username
That is, unless GNUTLS_ALLOW_ID_CHANGE is specified, during a rehandshake clients will not be allowed to present another certificate than the original, or change their username for PSK or SRP ciphersuites.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 0d434a7206..39646770ef 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -77,7 +77,7 @@ COBJECTS = range.c record.c compress.c debug.c cipher.c \
system_override.c crypto-backend.c verify-tofu.c pin.c tpm.c fips.c \
safe-memfuncs.c inet_pton.c atfork.c atfork.h randomart.c \
system-keys.h urls.c urls.h prf.c auto-verify.c dh-session.c \
- cert-session.c
+ cert-session.c handshake-checks.c
if WINDOWS
COBJECTS += system-keys-win.c