summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2013-12-17 18:36:01 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2013-12-17 18:36:01 +0100
commit56ae2368b333682ba63eb75090f46d65d0357d00 (patch)
tree228a96f12b55f793b4a736ad2593389e4a6b89ae /lib/Makefile.am
parent40125c81ea4f6152b6922485896e6e6d5b99c50c (diff)
downloadgnutls-56ae2368b333682ba63eb75090f46d65d0357d00.tar.gz
the accelerated library is depending on nettle being present
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 6c775711f7..40623aed02 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -20,11 +20,15 @@
ACLOCAL_AMFLAGS = -I ../m4 -I ../gl/m4
-SUBDIRS = includes x509 accelerated auth ext algorithms extras
+SUBDIRS = includes x509 auth ext algorithms extras
if ENABLE_MINITASN1
SUBDIRS += minitasn1
endif
+if ENABLE_NETTLE
+SUBDIRS += accelerated
+endif
+
localedir = $(datadir)/locale
AM_CFLAGS = $(WERROR_CFLAGS) $(WSTACK_CFLAGS) $(WARN_CFLAGS) $(NETTLE_CFLAGS)
@@ -121,13 +125,17 @@ libgnutls_la_LDFLAGS = -no-undefined \
-version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
libgnutls_la_LIBADD = ../gl/libgnu.la x509/libgnutls_x509.la \
- accelerated/libaccelerated.la ext/libgnutls_ext.la \
+ ext/libgnutls_ext.la \
auth/libgnutls_auth.la algorithms/libgnutls_alg.la \
extras/libgnutls_extras.la
thirdparty_libadd = $(LTLIBZ) $(LTLIBINTL) $(LIBSOCKET) \
$(LTLIBPTHREAD) $(LTLIBICONV) $(P11_KIT_LIBS) $(LIB_SELECT) $(TSS_LIBS) \
$(LTLIBICONV)
+if ENABLE_NETTLE
+libgnutls_la_LIBADD += accelerated/libaccelerated.la
+endif
+
if NEEDS_LIBRT
thirdparty_libadd += $(LTLIBRT)
endif