summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2019-10-20 18:49:41 +0300
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2019-10-24 17:23:49 +0300
commitcad80e6184135ea65f6f46a9abf9c1534486deab (patch)
tree902725a128204593fdb209ca9563fa7deb6edb7a /lib/Makefile.am
parente4a7db34259295ebb32a0255215471323948efbb (diff)
downloadgnutls-cad80e6184135ea65f6f46a9abf9c1534486deab.tar.gz
lib: drop gnutls_uint64 usage as sequence number
GnuTLS is depending already on uint64_t being a properly defined type. So there is no need to have a special byte-array type for 8-byte integers. Use uint64_t instead, thus simplifying a code quite heavily. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 9fe78afbdc..f1e3bb90b6 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -66,7 +66,7 @@ SRP_COBJECTS = srp.c
PSK_COBJECTS = psk.c
COBJECTS = range.c record.c compress.c debug.c cipher.c gthreads.h handshake-tls13.c \
- mbuffers.c buffers.c handshake.c num.c errors.c dh.c kx.c cipher-cbc.c \
+ mbuffers.c buffers.c handshake.c errors.c dh.c kx.c cipher-cbc.c \
priority.c hash_int.c cipher_int.c session.c db.c x509_b64.c \
hello_ext.c auth.c sslv2_compat.c datum.c session_pack.c mpi.c \
pk.c cert-cred.c global.c constate.c anon_cred.c pkix_asn1_tab.c gnutls_asn1_tab.c \