summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2014-03-19 13:39:19 +0100
committerNikos Mavrogiannopoulos <nmav@redhat.com>2014-03-19 13:39:19 +0100
commitf5ba2f41c2d87a1e7cf2f69fba878f281edf2e29 (patch)
treeaaaca41daac672c1f94b13fa1e3e32146b376b87 /lib/Makefile.am
parentde270f06a40b7ff45d478b17709fb8e118434972 (diff)
downloadgnutls-f5ba2f41c2d87a1e7cf2f69fba878f281edf2e29.tar.gz
ship the gperf file and the generated one.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index e2432dc2c4..3abf259315 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -20,6 +20,7 @@
ACLOCAL_AMFLAGS = -I ../m4 -I ../gl/m4
+EXTRA_DIST = priority_options.gperf
BUILT_SOURCES = pkix_asn1_tab.c gnutls_asn1_tab.c priority_options.h
SUBDIRS = includes x509 auth ext algorithms extras accelerated
@@ -107,7 +108,8 @@ HFILES = abstract_int.h debug.h gnutls_compress.h gnutls_cipher.h \
gnutls_state.h gnutls_x509.h crypto-backend.h \
gnutls_srp.h auth/srp.h auth/srp_passwd.h \
gnutls_helper.h gnutls_supplemental.h crypto.h random.h system.h\
- locks.h gnutls_mbuffers.h gnutls_ecc.h pin.h fips.h
+ locks.h gnutls_mbuffers.h gnutls_ecc.h pin.h fips.h \
+ priority_options.h
if ENABLE_PKCS11
HFILES += pkcs11_int.h
@@ -205,5 +207,5 @@ gnutls_asn1_tab.c: $(srcdir)/gnutls.asn
-asn1Parser $(srcdir)/gnutls.asn gnutls_asn1_tab.c
priority_options.h: $(srcdir)/priority_options.gperf
- -gperf -t $^ > $@
+ -gperf -t $^ > $@-tmp && mv $@-tmp $@