summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2010-05-21 17:00:01 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2010-06-03 19:52:32 +0200
commitbfff18e96db1423e243a800db8fc3e74df51551e (patch)
treea2eef6ac82474038e415e8cbeccc3e1cee5e4f73 /lib/Makefile.am
parentc0a6ea5047acd66707f3c2688016c29e888ee4b9 (diff)
downloadgnutls-bfff18e96db1423e243a800db8fc3e74df51551e.tar.gz
Added support for libnettle backend. This uses gmp for big number operations.
It is not currently completed. It lacks RSA blinding as well as optimizations.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 0f738a3ce9..061184035b 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -99,6 +99,12 @@ if ENABLE_PKCS11
COBJECTS += pkcs11.c pkcs11_privkey.c
endif
+if ENABLE_NETTLE
+SUBDIRS += nettle
+else
+SUBDIRS += gcrypt
+endif
+
if ENABLE_OPRFI
COBJECTS += $(OPRFI_COBJECTS)
endif