summaryrefslogtreecommitdiff
path: root/gl/tests/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2011-10-27 09:22:50 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2011-10-27 09:22:50 +0200
commitd86ab06220f5148db3a664d5659b4ec3f35d1079 (patch)
treec3cb111c1c77b773ecf13a49fb521b6a5269bdab /gl/tests/Makefile.am
parent482635401b91171259c9a027d0bc2faefb7e8c68 (diff)
downloadgnutls-d86ab06220f5148db3a664d5659b4ec3f35d1079.tar.gz
Added recv(), send(), connect() and inet_ntop() gnulib modules.
Diffstat (limited to 'gl/tests/Makefile.am')
-rw-r--r--gl/tests/Makefile.am36
1 files changed, 27 insertions, 9 deletions
diff --git a/gl/tests/Makefile.am b/gl/tests/Makefile.am
index 205b736bbc..4759912e18 100644
--- a/gl/tests/Makefile.am
+++ b/gl/tests/Makefile.am
@@ -142,15 +142,6 @@ EXTRA_DIST += test-close.c signature.h macros.h
## end gnulib module close-tests
-## begin gnulib module connect
-
-
-EXTRA_DIST += connect.c w32sock.h
-
-EXTRA_libtests_a_SOURCES += connect.c
-
-## end gnulib module connect
-
## begin gnulib module connect-tests
TESTS += test-connect
@@ -500,6 +491,15 @@ EXTRA_DIST += test-ignore-value.c
## end gnulib module ignore-value-tests
+## begin gnulib module inet_ntop-tests
+
+TESTS += test-inet_ntop
+check_PROGRAMS += test-inet_ntop
+test_inet_ntop_LDADD = $(LDADD) @INET_NTOP_LIB@
+EXTRA_DIST += test-inet_ntop.c signature.h macros.h
+
+## end gnulib module inet_ntop-tests
+
## begin gnulib module inet_pton-tests
TESTS += test-inet_pton
@@ -816,6 +816,15 @@ EXTRA_DIST += test-read-file.c
## end gnulib module read-file-tests
+## begin gnulib module recv-tests
+
+TESTS += test-recv
+check_PROGRAMS += test-recv
+test_recv_LDADD = $(LDADD) @LIBSOCKET@
+EXTRA_DIST += test-recv.c signature.h macros.h
+
+## end gnulib module recv-tests
+
## begin gnulib module recvfrom-tests
TESTS += test-recvfrom
@@ -844,6 +853,15 @@ EXTRA_DIST += macros.h signature.h test-select.c test-select.h test-select-fd.c
## end gnulib module select-tests
+## begin gnulib module send-tests
+
+TESTS += test-send
+check_PROGRAMS += test-send
+test_send_LDADD = $(LDADD) @LIBSOCKET@
+EXTRA_DIST += test-send.c signature.h macros.h
+
+## end gnulib module send-tests
+
## begin gnulib module sendto-tests
TESTS += test-sendto