summaryrefslogtreecommitdiff
path: root/gl/Makefile.am
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2005-10-17 13:16:40 +0000
committerSimon Josefsson <simon@josefsson.org>2005-10-17 13:16:40 +0000
commitbd20ac4950b3cd86a733184a1195e6071c281837 (patch)
tree833b1e29ba9fa9017593445ac5ef5bf825ba0c30 /gl/Makefile.am
parentaa9627dbca1ce74df9855d2c7a38c00dd88f4d87 (diff)
downloadgnutls-bd20ac4950b3cd86a733184a1195e6071c281837.tar.gz
UPdate.
Diffstat (limited to 'gl/Makefile.am')
-rw-r--r--gl/Makefile.am22
1 files changed, 21 insertions, 1 deletions
diff --git a/gl/Makefile.am b/gl/Makefile.am
index 1e164be1bc..bcb0c60784 100644
--- a/gl/Makefile.am
+++ b/gl/Makefile.am
@@ -8,7 +8,7 @@
# the same distribution terms as the rest of that program.
#
# Generated by gnulib-tool.
-# Reproduce by: gnulib-tool --import --dir=. --lib=libgnu --source-base=gl --m4-base=gl/m4 --aux-dir=. --lgpl --libtool --macro-prefix=gl getline getpass inet_ntop memmem memmove minmax readline snprintf socklen
+# Reproduce by: gnulib-tool --import --dir=. --lib=libgnu --source-base=gl --m4-base=gl/m4 --aux-dir=. --lgpl --libtool --macro-prefix=gl gc gc-pbkdf2-sha1 getline getpass inet_ntop memmem memmove minmax readline snprintf socklen
AUTOMAKE_OPTIONS = 1.5 gnits no-dependencies
@@ -38,6 +38,12 @@ MOSTLYCLEANFILES += alloca.h alloca.h-t
## end gnulib module alloca-opt
+## begin gnulib module gc
+
+libgnu_la_LIBADD += $(LIBGCRYPT)
+
+## end gnulib module gc
+
## begin gnulib module inet_ntop
libgnu_la_SOURCES += inet_ntop.h
@@ -82,6 +88,20 @@ MOSTLYCLEANFILES += stdbool.h stdbool.h-t
## end gnulib module stdbool
+## begin gnulib module stdint
+
+BUILT_SOURCES += $(STDINT_H)
+EXTRA_DIST += stdint_.h
+
+# We need the following in order to create <stdint.h> when the system
+# doesn't have one that works with the given compiler.
+stdint.h: stdint_.h
+ sed -e 's/@''HAVE_LONG_64BIT''@/$(HAVE_LONG_64BIT)/g;s/@''HAVE_LONG_LONG_64BIT@/$(HAVE_LONG_LONG_64BIT)/g' < $(srcdir)/stdint_.h > $@-t
+ mv $@-t $@
+MOSTLYCLEANFILES += stdint.h stdint.h-t
+
+## end gnulib module stdint
+
## begin gnulib module vasnprintf
libgnu_la_SOURCES += printf-args.h printf-parse.h vasnprintf.h