summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@redhat.com>2020-03-24 17:51:56 +0100
committerDaiki Ueno <ueno@gnu.org>2020-05-12 11:12:05 +0200
commitbb3e18e90697cfb2a583aab62aa3ae2b4552b974 (patch)
treef022eaec6be2d67dbc64a475795301a30b4f7a1e /doc/Makefile.am
parent0958603e5a827468f2d8a7b8b6e662fb9d3a7909 (diff)
downloadgnutls-bb3e18e90697cfb2a583aab62aa3ae2b4552b974.tar.gz
alert: add callback to intercept alert messagestmp-quic
This adds gnutls_alert_set_read_function(), to allow QUIC implementations to be notified when an alert message is sent. Signed-off-by: Daiki Ueno <dueno@redhat.com>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 67a79e5422..92bf3cce2d 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -658,6 +658,8 @@ FUNCS += functions/gnutls_alert_send
FUNCS += functions/gnutls_alert_send.short
FUNCS += functions/gnutls_alert_send_appropriate
FUNCS += functions/gnutls_alert_send_appropriate.short
+FUNCS += functions/gnutls_alert_set_read_function
+FUNCS += functions/gnutls_alert_set_read_function.short
FUNCS += functions/gnutls_alpn_get_selected_protocol
FUNCS += functions/gnutls_alpn_get_selected_protocol.short
FUNCS += functions/gnutls_alpn_set_protocols