summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2015-04-04 12:04:34 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2015-04-04 12:04:34 +0200
commit7bcb28f514c0153c9a58484e40dfd5c6908ddd2e (patch)
tree001d87ab035e045373aafbd110a965f52b93432e /doc/Makefile.am
parent9e345d269b20c349b197f81b0342bb2ce17caa4e (diff)
downloadgnutls-7bcb28f514c0153c9a58484e40dfd5c6908ddd2e.tar.gz
doc: updated makefiles to include new functions
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am57
1 files changed, 43 insertions, 14 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 9930f92cbd..b0f226100b 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -530,6 +530,7 @@ ENUMS += enums/gnutls_compression_method_t
ENUMS += enums/gnutls_credentials_type_t
ENUMS += enums/gnutls_digest_algorithm_t
ENUMS += enums/gnutls_ecc_curve_t
+ENUMS += enums/gnutls_ext_parse_type_t
ENUMS += enums/gnutls_handshake_description_t
ENUMS += enums/gnutls_kx_algorithm_t
ENUMS += enums/gnutls_mac_algorithm_t
@@ -645,6 +646,8 @@ FUNCS += functions/gnutls_auth_get_type
FUNCS += functions/gnutls_auth_get_type.short
FUNCS += functions/gnutls_auth_server_get_type
FUNCS += functions/gnutls_auth_server_get_type.short
+FUNCS += functions/gnutls_buffer_append_data
+FUNCS += functions/gnutls_buffer_append_data.short
FUNCS += functions/gnutls_bye
FUNCS += functions/gnutls_bye.short
FUNCS += functions/gnutls_certificate_activation_time_peers
@@ -829,6 +832,14 @@ FUNCS += functions/gnutls_credentials_get
FUNCS += functions/gnutls_credentials_get.short
FUNCS += functions/gnutls_credentials_set
FUNCS += functions/gnutls_credentials_set.short
+FUNCS += functions/gnutls_crypto_register_aead_cipher
+FUNCS += functions/gnutls_crypto_register_aead_cipher.short
+FUNCS += functions/gnutls_crypto_register_cipher
+FUNCS += functions/gnutls_crypto_register_cipher.short
+FUNCS += functions/gnutls_crypto_register_digest
+FUNCS += functions/gnutls_crypto_register_digest.short
+FUNCS += functions/gnutls_crypto_register_mac
+FUNCS += functions/gnutls_crypto_register_mac.short
FUNCS += functions/gnutls_db_check_entry
FUNCS += functions/gnutls_db_check_entry.short
FUNCS += functions/gnutls_db_check_entry_time
@@ -921,6 +932,12 @@ FUNCS += functions/gnutls_error_to_alert
FUNCS += functions/gnutls_error_to_alert.short
FUNCS += functions/gnutls_est_record_overhead_size
FUNCS += functions/gnutls_est_record_overhead_size.short
+FUNCS += functions/gnutls_ext_get_data
+FUNCS += functions/gnutls_ext_get_data.short
+FUNCS += functions/gnutls_ext_register
+FUNCS += functions/gnutls_ext_register.short
+FUNCS += functions/gnutls_ext_set_data
+FUNCS += functions/gnutls_ext_set_data.short
FUNCS += functions/gnutls_fingerprint
FUNCS += functions/gnutls_fingerprint.short
FUNCS += functions/gnutls_fips140_mode_enabled
@@ -1109,6 +1126,8 @@ FUNCS += functions/gnutls_ocsp_status_request_get
FUNCS += functions/gnutls_ocsp_status_request_get.short
FUNCS += functions/gnutls_ocsp_status_request_is_checked
FUNCS += functions/gnutls_ocsp_status_request_is_checked.short
+FUNCS += functions/gnutls_openpgp_crt_check_email
+FUNCS += functions/gnutls_openpgp_crt_check_email.short
FUNCS += functions/gnutls_openpgp_crt_check_hostname
FUNCS += functions/gnutls_openpgp_crt_check_hostname.short
FUNCS += functions/gnutls_openpgp_crt_check_hostname2
@@ -1269,12 +1288,12 @@ FUNCS += functions/gnutls_pcert_list_import_x509_raw
FUNCS += functions/gnutls_pcert_list_import_x509_raw.short
FUNCS += functions/gnutls_pem_base64_decode
FUNCS += functions/gnutls_pem_base64_decode.short
-FUNCS += functions/gnutls_pem_base64_decode_alloc
-FUNCS += functions/gnutls_pem_base64_decode_alloc.short
+FUNCS += functions/gnutls_pem_base64_decode2
+FUNCS += functions/gnutls_pem_base64_decode2.short
FUNCS += functions/gnutls_pem_base64_encode
FUNCS += functions/gnutls_pem_base64_encode.short
-FUNCS += functions/gnutls_pem_base64_encode_alloc
-FUNCS += functions/gnutls_pem_base64_encode_alloc.short
+FUNCS += functions/gnutls_pem_base64_encode2
+FUNCS += functions/gnutls_pem_base64_encode2.short
FUNCS += functions/gnutls_perror
FUNCS += functions/gnutls_perror.short
FUNCS += functions/gnutls_pk_algorithm_get_name
@@ -1289,8 +1308,12 @@ FUNCS += functions/gnutls_pkcs11_copy_secret_key
FUNCS += functions/gnutls_pkcs11_copy_secret_key.short
FUNCS += functions/gnutls_pkcs11_copy_x509_crt
FUNCS += functions/gnutls_pkcs11_copy_x509_crt.short
+FUNCS += functions/gnutls_pkcs11_copy_x509_crt2
+FUNCS += functions/gnutls_pkcs11_copy_x509_crt2.short
FUNCS += functions/gnutls_pkcs11_copy_x509_privkey
FUNCS += functions/gnutls_pkcs11_copy_x509_privkey.short
+FUNCS += functions/gnutls_pkcs11_copy_x509_privkey2
+FUNCS += functions/gnutls_pkcs11_copy_x509_privkey2.short
FUNCS += functions/gnutls_pkcs11_crt_is_known
FUNCS += functions/gnutls_pkcs11_crt_is_known.short
FUNCS += functions/gnutls_pkcs11_deinit
@@ -1333,6 +1356,8 @@ FUNCS += functions/gnutls_pkcs11_obj_list_import_url3
FUNCS += functions/gnutls_pkcs11_obj_list_import_url3.short
FUNCS += functions/gnutls_pkcs11_obj_list_import_url4
FUNCS += functions/gnutls_pkcs11_obj_list_import_url4.short
+FUNCS += functions/gnutls_pkcs11_obj_set_info
+FUNCS += functions/gnutls_pkcs11_obj_set_info.short
FUNCS += functions/gnutls_pkcs11_obj_set_pin_function
FUNCS += functions/gnutls_pkcs11_obj_set_pin_function.short
FUNCS += functions/gnutls_pkcs11_privkey_cpy
@@ -1347,6 +1372,8 @@ FUNCS += functions/gnutls_pkcs11_privkey_generate
FUNCS += functions/gnutls_pkcs11_privkey_generate.short
FUNCS += functions/gnutls_pkcs11_privkey_generate2
FUNCS += functions/gnutls_pkcs11_privkey_generate2.short
+FUNCS += functions/gnutls_pkcs11_privkey_generate3
+FUNCS += functions/gnutls_pkcs11_privkey_generate3.short
FUNCS += functions/gnutls_pkcs11_privkey_get_info
FUNCS += functions/gnutls_pkcs11_privkey_get_info.short
FUNCS += functions/gnutls_pkcs11_privkey_get_pk_algorithm
@@ -1573,8 +1600,6 @@ FUNCS += functions/gnutls_privkey_sign_data
FUNCS += functions/gnutls_privkey_sign_data.short
FUNCS += functions/gnutls_privkey_sign_hash
FUNCS += functions/gnutls_privkey_sign_hash.short
-FUNCS += functions/gnutls_privkey_sign_raw_data
-FUNCS += functions/gnutls_privkey_sign_raw_data.short
FUNCS += functions/gnutls_privkey_status
FUNCS += functions/gnutls_privkey_status.short
FUNCS += functions/gnutls_privkey_verify_params
@@ -1655,8 +1680,6 @@ FUNCS += functions/gnutls_pubkey_import_openpgp_raw
FUNCS += functions/gnutls_pubkey_import_openpgp_raw.short
FUNCS += functions/gnutls_pubkey_import_pkcs11
FUNCS += functions/gnutls_pubkey_import_pkcs11.short
-FUNCS += functions/gnutls_pubkey_import_pkcs11_url
-FUNCS += functions/gnutls_pubkey_import_pkcs11_url.short
FUNCS += functions/gnutls_pubkey_import_privkey
FUNCS += functions/gnutls_pubkey_import_privkey.short
FUNCS += functions/gnutls_pubkey_import_rsa_raw
@@ -1723,8 +1746,6 @@ FUNCS += functions/gnutls_record_send
FUNCS += functions/gnutls_record_send.short
FUNCS += functions/gnutls_record_send_range
FUNCS += functions/gnutls_record_send_range.short
-FUNCS += functions/gnutls_record_set_max_empty_records
-FUNCS += functions/gnutls_record_set_max_empty_records.short
FUNCS += functions/gnutls_record_set_max_size
FUNCS += functions/gnutls_record_set_max_size.short
FUNCS += functions/gnutls_record_set_state
@@ -1821,12 +1842,12 @@ FUNCS += functions/gnutls_srp_allocate_server_credentials
FUNCS += functions/gnutls_srp_allocate_server_credentials.short
FUNCS += functions/gnutls_srp_base64_decode
FUNCS += functions/gnutls_srp_base64_decode.short
-FUNCS += functions/gnutls_srp_base64_decode_alloc
-FUNCS += functions/gnutls_srp_base64_decode_alloc.short
+FUNCS += functions/gnutls_srp_base64_decode2
+FUNCS += functions/gnutls_srp_base64_decode2.short
FUNCS += functions/gnutls_srp_base64_encode
FUNCS += functions/gnutls_srp_base64_encode.short
-FUNCS += functions/gnutls_srp_base64_encode_alloc
-FUNCS += functions/gnutls_srp_base64_encode_alloc.short
+FUNCS += functions/gnutls_srp_base64_encode2
+FUNCS += functions/gnutls_srp_base64_encode2.short
FUNCS += functions/gnutls_srp_free_client_credentials
FUNCS += functions/gnutls_srp_free_client_credentials.short
FUNCS += functions/gnutls_srp_free_server_credentials
@@ -1881,6 +1902,12 @@ FUNCS += functions/gnutls_subject_alt_names_set
FUNCS += functions/gnutls_subject_alt_names_set.short
FUNCS += functions/gnutls_supplemental_get_name
FUNCS += functions/gnutls_supplemental_get_name.short
+FUNCS += functions/gnutls_supplemental_recv
+FUNCS += functions/gnutls_supplemental_recv.short
+FUNCS += functions/gnutls_supplemental_register
+FUNCS += functions/gnutls_supplemental_register.short
+FUNCS += functions/gnutls_supplemental_send
+FUNCS += functions/gnutls_supplemental_send.short
FUNCS += functions/gnutls_system_key_add_x509
FUNCS += functions/gnutls_system_key_add_x509.short
FUNCS += functions/gnutls_system_key_delete
@@ -2147,6 +2174,8 @@ FUNCS += functions/gnutls_x509_crq_sign2
FUNCS += functions/gnutls_x509_crq_sign2.short
FUNCS += functions/gnutls_x509_crq_verify
FUNCS += functions/gnutls_x509_crq_verify.short
+FUNCS += functions/gnutls_x509_crt_check_email
+FUNCS += functions/gnutls_x509_crt_check_email.short
FUNCS += functions/gnutls_x509_crt_check_hostname
FUNCS += functions/gnutls_x509_crt_check_hostname.short
FUNCS += functions/gnutls_x509_crt_check_hostname2