summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2017-05-29 08:43:14 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2017-05-29 09:26:56 +0200
commit7de197b5757ce5da407776a7ab8faadfd658f7e6 (patch)
tree35a0062badde783858402376257752d9e07ee0f4 /doc/Makefile.am
parent0f308c448445613a2b294ff5be0ba9a110f30e66 (diff)
downloadgnutls-7de197b5757ce5da407776a7ab8faadfd658f7e6.tar.gz
updated auto-generated files
Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 500f332860..f02875f096 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1820,6 +1820,8 @@ FUNCS += functions/gnutls_sign_is_secure
FUNCS += functions/gnutls_sign_is_secure.short
FUNCS += functions/gnutls_sign_list
FUNCS += functions/gnutls_sign_list.short
+FUNCS += functions/gnutls_sign_supports_pk_algorithm
+FUNCS += functions/gnutls_sign_supports_pk_algorithm.short
FUNCS += functions/gnutls_srp_allocate_client_credentials
FUNCS += functions/gnutls_srp_allocate_client_credentials.short
FUNCS += functions/gnutls_srp_allocate_server_credentials
@@ -2120,6 +2122,8 @@ FUNCS += functions/gnutls_x509_crq_get_key_usage
FUNCS += functions/gnutls_x509_crq_get_key_usage.short
FUNCS += functions/gnutls_x509_crq_get_pk_algorithm
FUNCS += functions/gnutls_x509_crq_get_pk_algorithm.short
+FUNCS += functions/gnutls_x509_crq_get_pk_algorithm2
+FUNCS += functions/gnutls_x509_crq_get_pk_algorithm2.short
FUNCS += functions/gnutls_x509_crq_get_pk_oid
FUNCS += functions/gnutls_x509_crq_get_pk_oid.short
FUNCS += functions/gnutls_x509_crq_get_private_key_usage_period
@@ -2164,6 +2168,8 @@ FUNCS += functions/gnutls_x509_crq_set_key_rsa_raw
FUNCS += functions/gnutls_x509_crq_set_key_rsa_raw.short
FUNCS += functions/gnutls_x509_crq_set_key_usage
FUNCS += functions/gnutls_x509_crq_set_key_usage.short
+FUNCS += functions/gnutls_x509_crq_set_pk_algorithm
+FUNCS += functions/gnutls_x509_crq_set_pk_algorithm.short
FUNCS += functions/gnutls_x509_crq_set_private_key_usage_period
FUNCS += functions/gnutls_x509_crq_set_private_key_usage_period.short
FUNCS += functions/gnutls_x509_crq_set_pubkey
@@ -2280,6 +2286,8 @@ FUNCS += functions/gnutls_x509_crt_get_name_constraints
FUNCS += functions/gnutls_x509_crt_get_name_constraints.short
FUNCS += functions/gnutls_x509_crt_get_pk_algorithm
FUNCS += functions/gnutls_x509_crt_get_pk_algorithm.short
+FUNCS += functions/gnutls_x509_crt_get_pk_algorithm2
+FUNCS += functions/gnutls_x509_crt_get_pk_algorithm2.short
FUNCS += functions/gnutls_x509_crt_get_pk_dsa_raw
FUNCS += functions/gnutls_x509_crt_get_pk_dsa_raw.short
FUNCS += functions/gnutls_x509_crt_get_pk_ecc_raw
@@ -2396,6 +2404,8 @@ FUNCS += functions/gnutls_x509_crt_set_name_constraints
FUNCS += functions/gnutls_x509_crt_set_name_constraints.short
FUNCS += functions/gnutls_x509_crt_set_pin_function
FUNCS += functions/gnutls_x509_crt_set_pin_function.short
+FUNCS += functions/gnutls_x509_crt_set_pk_algorithm
+FUNCS += functions/gnutls_x509_crt_set_pk_algorithm.short
FUNCS += functions/gnutls_x509_crt_set_policy
FUNCS += functions/gnutls_x509_crt_set_policy.short
FUNCS += functions/gnutls_x509_crt_set_private_key_usage_period
@@ -2580,6 +2590,8 @@ FUNCS += functions/gnutls_x509_privkey_get_pk_algorithm
FUNCS += functions/gnutls_x509_privkey_get_pk_algorithm.short
FUNCS += functions/gnutls_x509_privkey_get_pk_algorithm2
FUNCS += functions/gnutls_x509_privkey_get_pk_algorithm2.short
+FUNCS += functions/gnutls_x509_privkey_get_pk_algorithm3
+FUNCS += functions/gnutls_x509_privkey_get_pk_algorithm3.short
FUNCS += functions/gnutls_x509_privkey_get_seed
FUNCS += functions/gnutls_x509_privkey_get_seed.short
FUNCS += functions/gnutls_x509_privkey_import
@@ -2622,6 +2634,22 @@ FUNCS += functions/gnutls_x509_rdn_get_by_oid
FUNCS += functions/gnutls_x509_rdn_get_by_oid.short
FUNCS += functions/gnutls_x509_rdn_get_oid
FUNCS += functions/gnutls_x509_rdn_get_oid.short
+FUNCS += functions/gnutls_x509_spki_deinit
+FUNCS += functions/gnutls_x509_spki_deinit.short
+FUNCS += functions/gnutls_x509_spki_get_digest_algorithm
+FUNCS += functions/gnutls_x509_spki_get_digest_algorithm.short
+FUNCS += functions/gnutls_x509_spki_get_pk_algorithm
+FUNCS += functions/gnutls_x509_spki_get_pk_algorithm.short
+FUNCS += functions/gnutls_x509_spki_get_salt_size
+FUNCS += functions/gnutls_x509_spki_get_salt_size.short
+FUNCS += functions/gnutls_x509_spki_init
+FUNCS += functions/gnutls_x509_spki_init.short
+FUNCS += functions/gnutls_x509_spki_set_digest_algorithm
+FUNCS += functions/gnutls_x509_spki_set_digest_algorithm.short
+FUNCS += functions/gnutls_x509_spki_set_pk_algorithm
+FUNCS += functions/gnutls_x509_spki_set_pk_algorithm.short
+FUNCS += functions/gnutls_x509_spki_set_salt_size
+FUNCS += functions/gnutls_x509_spki_set_salt_size.short
FUNCS += functions/gnutls_x509_tlsfeatures_add
FUNCS += functions/gnutls_x509_tlsfeatures_add.short
FUNCS += functions/gnutls_x509_tlsfeatures_check_crt