summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2014-03-10 13:09:54 +0100
committerNikos Mavrogiannopoulos <nmav@redhat.com>2014-03-10 13:21:49 +0100
commit7ceac79d4a1b7484efd4b7e8cf217355ba3c6994 (patch)
tree7eedb2fb3fab153536eae685429b9ff5205d1e0c /doc/Makefile.am
parentac946390530caea325111c10c2e437ecd5f3cd77 (diff)
downloadgnutls-7ceac79d4a1b7484efd4b7e8cf217355ba3c6994.tar.gz
The xssl experimental library was removed.
While the idea of a high level library is nice, there are no resources to maintain an additional library.
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am42
1 files changed, 3 insertions, 39 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 73fe681713..aa1f2feb5a 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -202,8 +202,7 @@ MAINTAINERCLEANFILES =
API_FILES=gnutls-api.texi x509-api.texi pgp-api.texi pkcs12-api.texi \
tpm-api.texi pkcs11-api.texi abstract-api.texi compat-api.texi \
- dtls-api.texi crypto-api.texi ocsp-api.texi tpm-api.texi dane-api.texi \
- xssl-api.texi
+ dtls-api.texi crypto-api.texi ocsp-api.texi tpm-api.texi dane-api.texi
clean-local:
-rm -f stamp_enums stamp_functions
@@ -247,17 +246,6 @@ x509-api.texi: $(top_srcdir)/lib/includes/gnutls/x509.h
done
mv -f $@-tmp $@
-xssl-api.texi: $(top_srcdir)/lib/includes/gnutls/xssl.h
- echo "" > $@-tmp
- for i in `$(top_srcdir)/doc/scripts/getfuncs.pl < $< |sort|uniq`; do \
- echo $(ECHO_N) "Creating documentation for $$i... " && \
- $(srcdir)/scripts/gdoc -texinfo \
- -function $$i \
- $(C_SOURCE_FILES) >> $@-tmp 2>/dev/null && \
- echo "ok"; \
- done
- mv -f $@-tmp $@
-
pgp-api.texi: $(top_srcdir)/lib/includes/gnutls/openpgp.h
echo "" > $@-tmp
for i in `$(top_srcdir)/doc/scripts/getfuncs.pl < $< |sort|uniq`; do \
@@ -432,11 +420,11 @@ $(FUNCS): stamp_functions
compare-exported:
rm -f tmp-exp-$@ tmp-head-$@
for i in ../libdane/includes/gnutls/*.h ../lib/includes/gnutls/*.h;do perl scripts/getfuncs.pl <$$i >>tmp-head-$@;done
- sort -u tmp-head-$@|grep -v ^xssl > tmp2-head-$@
+ sort -u tmp-head-$@ > tmp2-head-$@
mv tmp2-head-$@ tmp-head-$@
scripts/getfuncs-map.pl <../lib/libgnutls.map >tmp-exp-$@
scripts/getfuncs-map.pl <../libdane/libdane.map >>tmp-exp-$@
- sort -u tmp-exp-$@|grep -v ^xssl > tmp2-exp-$@
+ sort -u tmp-exp-$@ > tmp2-exp-$@
mv tmp2-exp-$@ tmp-exp-$@
diff -u tmp-exp-$@ tmp-head-$@
rm -f tmp-exp-$@ tmp-head-$@
@@ -2379,27 +2367,3 @@ FUNCS += functions/gnutls_x509_trust_list_verify_crt
FUNCS += functions/gnutls_x509_trust_list_verify_crt.short
FUNCS += functions/gnutls_x509_trust_list_verify_named_crt
FUNCS += functions/gnutls_x509_trust_list_verify_named_crt.short
-FUNCS += functions/xssl_client_init
-FUNCS += functions/xssl_client_init.short
-FUNCS += functions/xssl_cred_deinit
-FUNCS += functions/xssl_cred_deinit.short
-FUNCS += functions/xssl_cred_init
-FUNCS += functions/xssl_cred_init.short
-FUNCS += functions/xssl_deinit
-FUNCS += functions/xssl_deinit.short
-FUNCS += functions/xssl_flush
-FUNCS += functions/xssl_flush.short
-FUNCS += functions/xssl_getdelim
-FUNCS += functions/xssl_getdelim.short
-FUNCS += functions/xssl_get_session
-FUNCS += functions/xssl_get_session.short
-FUNCS += functions/xssl_printf
-FUNCS += functions/xssl_printf.short
-FUNCS += functions/xssl_read
-FUNCS += functions/xssl_read.short
-FUNCS += functions/xssl_server_init
-FUNCS += functions/xssl_server_init.short
-FUNCS += functions/xssl_sinit
-FUNCS += functions/xssl_sinit.short
-FUNCS += functions/xssl_write
-FUNCS += functions/xssl_write.short