summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2004-08-15 20:20:39 +0000
committerSimon Josefsson <simon@josefsson.org>2004-08-15 20:20:39 +0000
commit894568e3be3697efa6fb17c7f7505346a93a3dfa (patch)
treec62bd85dd457554e40c77c6eeecdca360d1a244c /configure.in
parentb9dd0510e51b64c73a7f7c7a7d9f41ff6304bb36 (diff)
downloadgnutls-894568e3be3697efa6fb17c7f7505346a93a3dfa.tar.gz
Initiate move of all libgcrypt calls to crypto/gc* wrapper.
Currently only encryption/decryption goes through generic API.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 6ebb8db74b..15e8402a69 100644
--- a/configure.in
+++ b/configure.in
@@ -299,6 +299,10 @@ AM_PATH_LIBGCRYPT($GNUTLS_GCRYPT_VERSION,,
]]))
dnl Can't disable - gnutls depends on gcrypt
AC_DEFINE(USE_GCRYPT, 1, [use gcrypt])
+AC_SUBST(NETTLE_CFLAGS)
+AC_SUBST(NETTLE_LIBS)
+AM_CONDITIONAL(LIBGCRYPT, true)
+AM_CONDITIONAL(NETTLE, false)
AC_MSG_CHECKING([whether to disable SRP authentication support])
AC_ARG_ENABLE( srp-authentication, [ --disable-srp-authentication Disable the SRP authentication support],
@@ -606,6 +610,6 @@ doc/Makefile src/x509/Makefile src/srp/Makefile src/openpgp/Makefile \
src/cfg/Makefile src/cfg/platon/Makefile src/cfg/platon/str/Makefile \
doc/scripts/Makefile lib/minitasn1/Makefile lib/x509/Makefile \
includes/Makefile includes/gnutls/Makefile doc/manpages/Makefile \
-gl/Makefile tests/Makefile])
+gl/Makefile crypto/Makefile tests/Makefile])
AC_OUTPUT