summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2007-04-10 17:07:05 +0000
committerSimon Josefsson <simon@josefsson.org>2007-04-10 17:07:05 +0000
commit407ca9fdb24735dda0c5434b05a70c41be76cd63 (patch)
tree6a9e1df5c365fce1c624ca7399391c4bd9c1462e /configure.in
parent9cf0a597203099bf4fa2a4bcf4e7204ef9fdac3e (diff)
downloadgnutls-407ca9fdb24735dda0c5434b05a70c41be76cd63.tar.gz
Add --disable-tls-authorization.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 99fc7d7677..467463e2d8 100644
--- a/configure.in
+++ b/configure.in
@@ -340,6 +340,19 @@ else
AC_MSG_RESULT(yes)
fi
+AC_MSG_CHECKING([whether to disable authorization (tls-authz) support])
+AC_ARG_ENABLE(tls-authorization,
+ AS_HELP_STRING([--disable-tls-authorization],
+ [disable tls authorization support]),
+ ac_enable_authz=no)
+if test x$ac_enable_authz != xno; then
+ AC_MSG_RESULT(no)
+ AC_DEFINE(ENABLE_AUTHZ, 1, [enable tls authorization])
+else
+ ac_full=0
+ AC_MSG_RESULT(yes)
+fi
+
AC_MSG_CHECKING([whether to disable extra PKI stuff])
AC_ARG_ENABLE(extra-pki,
AS_HELP_STRING([--disable-extra-pki],